Bookmark deleted when right-clicking shortcut toolbar button and pressing 't'

RESOLVED DUPLICATE of bug 301888

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 301888
10 years ago
10 years ago

People

(Reporter: Darren, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

When on a web page, and i right-click a link to get an options menu, the link for Open Link in New Tab is 'T' and Open Link in New Window is 'W'.  

However, when right-clicking on a shortcut in the Bookmarks Toolbar, the action for the 'T' key is "Delete".

The result is that I often accidentally delete my shortcuts from the toolbar instead of opening that shortcut in a new tab.


Reproducible: Always

Steps to Reproduce:
1. Right-click on a link in the shortcut toolbar
2. Press 'T' on the keyboard
3. Watch your shortcut disappear
Actual Results:  
The shortcut got deleted

Expected Results:  
Same behaviour is "Open in a new Tab" context menu for a link on a web page

One would expect the same hot-keys in the context menu on a web page and in the shortcut menu, IE  'W' for open in new window and 'T' for open in new tab.

I realize that 'T' this is a standard windows key for "Cut", so perhaps changing the context menu the web link context menu to 'N' for new window and 'W' for new tab would be the alternative solution.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 301888
You need to log in before you can comment on or make changes to this bug.