Remove cookies button shifts

VERIFIED FIXED in Firefox 3.7a1

Status

()

VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: jmjeffery, Assigned: dao)

Tracking

({polish})

Trunk
Firefox 3.7a1
polish
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-easy][polish-interactive][polish-p3])

Attachments

(1 attachment, 3 obsolete attachments)

When opening Tools->Options->Privacy 

Click the 'show cookies' button 
When you have a site listed that has multiple cookies the button at the bottom for 'Remove Cookies'  will shift by 1- letter as it changes from:

Remove Cookie to Remove Cookies 

Button should NOT resize..
(Reporter)

Updated

11 years ago
Target Milestone: --- → Firefox 3
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
changing OS to ALL...i can see this also on Mac 10.5 and XP
OS: Windows Vista → All
Hardware: PC → All
Being as no-one is looking at this, and it appears no-where on any of the easy/hard UI fix-lists, I'm closing this as INVALID.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Might as well keep it open since it is a legitimate problem, just a low visibility one.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Whiteboard: [polish-easy][polish-interactive]

Comment 4

10 years ago
As a low visibility bug sounds like a good one to claim as my first:)

I was chatting with rs about this problem, we discussed different approaches that would all be a bit hacky as we do not know how long the button will be for each locale. Robb said we could just flip the two buttons and the button movement would pretty much go away. What do you think? - ddahl
I'm not sure I'm comfortable flipping the buttons, as "Remove All Cookies" is really destructive and doesn't have a confirmation button (bug ?) or an undo (bug 285836) function.

In order to not break string freeze, and to fix the jitter, I'd suggest just always using the plural entity ("Remove Cookies" in english) and not switching back and forth.

Updated

10 years ago
Assignee: nobody → ddahl

Comment 6

10 years ago
Created attachment 355874 [details] [diff] [review]
forcing the "remove cookies" button to always use the plural string

forcing the "remove cookies" button to always use the plural string, also removed code that supported figuring out if there are more than 1 cookie per domain.
Attachment #355874 - Flags: review?(mconnor)

Comment 7

10 years ago
Created attachment 355894 [details] [diff] [review]
trunk patch as per rstrong's guidance

Removed preferences.properties that are redundant, changed the name of cookies.dtd entities to fully clean up this patch
Attachment #355894 - Flags: review?(mconnor)
mconnor suggests "remove selected"

In general action buttons are supposed to be specific.  It's hard to say that getting the plural right is a whole lot better than not shifting, or vice versa.  Perhaps we should just fix this bug when we start up development for 3.2 since we are after the string freeze?  Or we could just land the current patch and fix the plural thing later.
(Assignee)

Comment 9

10 years ago
(In reply to comment #8)
> mconnor suggests "remove selected"

This wouldn't solve it for locales where "selected" changes depending on the item count.
Summary: Show cookies button shifts → Remove cookies button shifts
(Assignee)

Updated

10 years ago
Duplicate of this bug: 399786
(Assignee)

Updated

10 years ago
Target Milestone: Firefox 3 → ---
(Assignee)

Comment 11

10 years ago
Created attachment 356326 [details] [diff] [review]
fix the button size
(Assignee)

Comment 12

10 years ago
Created attachment 356328 [details] [diff] [review]
fix the button size, v2

This is slightly less messy. (There were also some parentheses missing in the previous patch.)
Attachment #356326 - Attachment is obsolete: true

Comment 13

10 years ago
I just applied your patch. Does this work with all locales as well?
(Assignee)

Comment 14

10 years ago
Yes, should work for all locales.

Updated

10 years ago
Attachment #356328 - Flags: review?(gavin.sharp)

Updated

10 years ago
Attachment #355894 - Flags: review?(mconnor)

Updated

10 years ago
Attachment #355874 - Flags: review?(mconnor)
This bug's priority relative to the set of other polish bugs is:
P3 - Polish issue that is in a secondary interface, occasionally encountered, or is not easily identifiable.

Problem should be pretty obvious, but buried kind of deep in our UI.
Whiteboard: [polish-easy][polish-interactive] → [polish-easy][polish-interactive][polish-p3]
Comment on attachment 356328 [details] [diff] [review]
fix the button size, v2

>diff --git a/browser/components/preferences/cookies.xul b/browser/components/preferences/cookies.xul

>+      <deck>
>+        <button id="removeCookie" disabled="true" icon="remove"
>+                label="&button.removecookie.label;" accesskey="&button.removecookie.accesskey;"
>+                oncommand="gCookiesWindow.deleteCookie();"/>
>+        <button id="removeCookies" disabled="true" icon="remove"
>+                label="&button.removecookies.label;" accesskey="&button.removecookie.accesskey;"
>+                oncommand="gCookiesWindow.deleteCookie();"/>
>+      </deck>

could put the oncommand on the <deck>
Attachment #356328 - Flags: review?(gavin.sharp) → review+
Assignee: ddahl → dao
(Assignee)

Updated

9 years ago
Attachment #355874 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Attachment #355894 - Attachment is obsolete: true
(Assignee)

Comment 17

9 years ago
http://hg.mozilla.org/mozilla-central/rev/f31a8b89f5dc
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
Verfied Fixed using hourly build:

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100124 Minefield/3.7a1pre ID:20100124101409
cset: http://hg.mozilla.org/mozilla-central/rev/b3b2e90f743d
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.