Big5 address with comma interpreted as two addresses

RESOLVED DUPLICATE of bug 254519

Status

RESOLVED DUPLICATE of bug 254519
11 years ago
11 years ago

People

(Reporter: 4aeikob02, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: version 2.0.0.12 (20080213)

I am receiving emails from China with From: and CC: addresses starting with the names stored in Big5 base64-encoded.  If I View Message Source, I see lines like this:

=?big5?B?[rest of the name is encoded here]?= <name@domain.com>,

When decoded, the part in the name area contains "lastname, firstname".  This is interpreted by Thunderbird as two separate addresses:

lastname
firstname <name@domain.com>

This shows up as two addresses in the From: field, for instance, and when I press Reply, each of these "addresses" is shown on a separate line in the To: area, giving me invalid email address errors for the lastnames when I try to send.

Reproducible: Always



Expected Results:  
Commas inside email names should be treated as part of the name, not as an inter-address separator, no matter what the encoding.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254519
You need to log in before you can comment on or make changes to this bug.