div boxes miss onMouseOver sometimes

RESOLVED WORKSFORME

Status

()

P3
minor
RESOLVED WORKSFORME
19 years ago
16 years ago

People

(Reporter: laotzu, Assigned: joki)

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: wdormann@crosswinds.net, URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test1 i686; en-US; m16) Gecko/20000615
BuildID:    2000061508

On the left hand side of this page is a menu with a bunch of links to other
pages. It's all done with CSS, and each box is a div class="nav-link". They all
have onMouseOver parameters too, that change the background color from black to
#006666. If you move your mouse to the far left of the top boxes, where there is
no text but just inside the box, it changes color. But on all the boxes past
'Networking', they only change color when your mouse is over the text in the box.

Reproducible: Always
Steps to Reproduce:
1. Visit http://www.eltanin.net/.
2. Move your mouse over the 'News' box. Observe how it is #006666 even when the
mouse is not over text.
3. Move your mouse down to the 'Staff' box. Observe how it is #000000 unless
your mouse is over the text. The box does not change color when you're not over
text.

Actual Results:  All boxes under 'Networking' only change color when the mouse
is over the text.

Expected Results:  All boxes should change color whenever the mouse passes their
border.

Comment 1

19 years ago
Confirmed Win32 2000061520
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: makingtest
OS: Linux → All
Whiteboard: wdormann@crosswinds.net

Comment 2

19 years ago
looks liek style sheets. wdormann - you one the test case?

Comment 3

19 years ago
Created attachment 10281 [details]
Simplified Testcase

Comment 4

19 years ago
With the testcase, moving the mouse over anywhere in DIV "A" makes the DIV 
green.   Yet, only moving the mouse over the mouse over the letter "C" in DIV C 
makes it green.

Perhaps some issue with DIV and  rowspan=2 ?
Keywords: makingtest → testcase

Comment 5

19 years ago
is this a style system issue or and HTML Element issue?

Comment 6

19 years ago
--> html element, taking the rowspan=2 away fixes this.
Assignee: asa → clayton
Component: Browser-General → HTML Element
QA Contact: doronr → petersen

Comment 7

19 years ago
Reassigning to myself.
Assignee: clayton → karnaze

Comment 8

19 years ago
Joki, I tried tracking this down with little success. I though possibly 
nsTableRowFrame::GetFrameForPoint (which I think you added) was not working 
correctly with rowspan=2 but I'm not sure.
Assignee: karnaze → joki
This bug has been marked "future" because the original netscape engineer
working on this is over-burdened. If you feel this is an error, that you or
another known resource will be working on this bug,or if it blocks your work in
some way -- please attach your concern to the bug for reconsideration.
Target Milestone: --- → Future

Comment 10

18 years ago
massive update for QA contact.
QA Contact: petersen → lorca

Comment 11

18 years ago
I have a problem with IFRAME's where they always drawn on top even when z-index 
of subsenquent elements are higher.  This is a grevious issue because the 
system we have places a DIV above the IFRAME, due to this bug the IFRAME is 
always displayed above the DIV and the DIV's contents are masked.  
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 13

18 years ago
qa contact updated.
QA Contact: gerardok → bsharma
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout

Updated

17 years ago
QA Contact: bsharma → moied

Comment 15

16 years ago
Seems to work in 1.3a

Comment 16

16 years ago
WFM build 2002123008, Windows XP
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.