De-hybridize the language tools page

VERIFIED FIXED in 3.4.1

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
10 years ago
2 years ago

People

(Reporter: clouserw, Assigned: wenzel)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
I don't think our language tools[1] page is very friendly right now.  When a new user goes to the page, unless they know to scroll down (or have a giant monitor) they won't know there is a list of locales.

We should revise the page to remove the 3 giant recommended add-ons at the top as I feel they are adding little value right now.  I'd like to see a smaller recommended box (maybe half of the style here [2]) that we could put at the top of the page that offers dictionaries and/or language packs in that users detected language.  We used to have a box at the top that attempted to do this, so one could argue a regression keyword for this part.

[1] https://addons.mozilla.org/en-US/firefox/browse/type:3
[2] https://addons.mozilla.org/en-US/firefox/browse/type:4/cat:all?sort=name
(Assignee)

Comment 1

10 years ago
I like the suggestion to improve user experience on that page. However, I believe we should consider removing the hybrid part from that page and making it a dictionary/lang pack page only. While we would still have two addon types on the same page, I believe combining *three* things on the same page is not the way to go.
I think I've come around to agreeing with this.  I could see us having two categories: "Language Tools" and "Languages and Dictionaries."  They were combined when we felt like we simply had too many categories and needed to consolidate where two categories shared enough of a theme (no pun intended).

Language packs and dictionaries still feel like they should be in the same list.
(Reporter)

Comment 3

10 years ago
(In reply to comment #1)
> I like the suggestion to improve user experience on that page. However, I
> believe we should consider removing the hybrid part from that page and making
> it a dictionary/lang pack page only. While we would still have two addon types
> on the same page, I believe combining *three* things on the same page is not
> the way to go.
> 

Yes with (perhaps!) an exception for the quick locale switcher.  A special box or recommendation somewhere - don't mix it in with the results and explain why it's there.

Comment 4

10 years ago
All of the above matches with my thinking.

And yeah, language switcher seems to be valuable, there may be more.

It seems to me that those wouldn't need to be more prominent than something in a sidebar.
(Reporter)

Updated

10 years ago
Target Milestone: --- → 3.4
(Reporter)

Comment 5

10 years ago
We want to split language tools so dictionaries and language packs are separate from other extensions.  Similar to bug 428033 for themes.
Summary: Revise recommended add-ons for language tools page → De-hybridize the language tools page
(Reporter)

Updated

10 years ago
Duplicate of this bug: 428251

Updated

10 years ago
Blocks: 426201

Updated

10 years ago
Target Milestone: 3.4 → 3.4.1

Updated

10 years ago
Assignee: nobody → fwenzel
(Assignee)

Comment 7

10 years ago
Created attachment 318119 [details] [diff] [review]
Language tools dehybridization

This patch de-hybridizes the language tools page.

For that, it was necessary to also change how category highlights are done, incidentally fixing bug 425503 too. I also remove all "breadcrumbs" from the add-ons controller because the two-level highlight code was the last place they were used in.
Attachment #318119 - Flags: review?(fligtar)
Comment on attachment 318119 [details] [diff] [review]
Language tools dehybridization

r=fligtar
Attachment #318119 - Flags: review?(fligtar) → review+
(Assignee)

Comment 9

10 years ago
Thanks for this review, too. The fix is in r12610. This part is done, however there are still some views I need to fix, which I will do as part of the remaining fix to bug 428033.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: push-needed
Resolution: --- → FIXED
Seems a little confusing that on https://preview.addons.mozilla.org/en-US/thunderbird/ we have:

"Dictionaries" - https://preview.addons.mozilla.org/en-US/thunderbird/browse/type:1/cat:69
"Dictionaries & Language Packs" - https://preview.addons.mozilla.org/en-US/thunderbird/browse/type:3

The latter goes straight to the Dictionary and Language Pack page (naturally), so that's fine; anything we can do to make the former category clearer (and more distinct)?
(Assignee)

Comment 11

10 years ago
How about "Language Tools" like we use for Firefox? Basil?

Comment 12

10 years ago
Yup, that makes sense Fred.
This is all verified fixed except for the category-name change mentioned in comment 10 and comment 11, which will happen when / shortly after we svn-up to pick-up the 3.4.1 changes in production; I'll verify it then.
(Reporter)

Updated

10 years ago
Keywords: push-needed
Verified FIXED in production; issues mentioned in comment 13 have been addressed.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.