css in XSL transformation

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: pinepain, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-09-15], URL)

Attachments

(1 attachment)

520 bytes, application/octet-stream
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080325 Ubuntu/7.10 (gutsy) Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080325 Ubuntu/7.10 (gutsy) Firefox/2.0.0.13

Css doesn't set <body> background color in XSLT transformed document, if there was set xhtml namespace in xsl sheet.

Reproducible: Always

Steps to Reproduce:
1. Open xml with link to xsl sheet
2. remove xhtm namespace in xsl stylesheet
3. Open xml with link to xsl sheet
Actual Results:  
Body has default colour

Expected Results:  
Body should have defined in css color

Interesting, that font-size works fine on body. Also if set some id to <body>, like <body id='test'> and set background to this id than everything works fine. One more thing, on other elements bg color works fine/

there are 3 files on freshcode.org/css_xslt/
test.xml - actually test xml
test.xsl - xsl style sheet for test.xml
test.css - css to use on transformed test.xml with test.xsl
(Reporter)

Comment 1

10 years ago
Created attachment 314663 [details]
files to test problem

add/remove xhtml namespace in test.xsl to test problem
Reporter, are you still seeing this issue with Firefox 3.6.x or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2010-09-15]
Version: unspecified → 2.0 Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.10 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

8 years ago
Sorry for such delay, I was in army =).

It works for me on win xp (linux wont works fine on hp 4510s vc430ea) with firefox 4.0 beta 5, so I think we could close this bug.
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.