<input type="text"> not respecting width correctly.

VERIFIED DUPLICATE of bug 42521

Status

()

P3
normal
VERIFIED DUPLICATE of bug 42521
19 years ago
19 years ago

People

(Reporter: jameslariviere, Assigned: rods)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
DESCRIPTION:

A <select> width is short by a few px's compared to both a <p> and input
[type="text"].

STEPS TO REPRODUCE:

View test case.

In the test case, all borders are set to 1px and width of 200 px for the input
[type="text"], <p> and <select>.

ACTUAL RESULTS:

notice that the <select> is short in width by a few pixels.

EXPECTED RESULTS:

ALL input[type="text"], <p> and <select> should have the same width.


DOES NOT WORK CORRECTLY ON:

Win98 build 2000061520 (6-15-00-m17 I think)
(Reporter)

Comment 1

19 years ago
Created attachment 10249 [details]
test case
Actually, I think the problem is with the INPUT element.

Add the following to your test case to see what I mean:

   * { box-sizing: content-box ! important; 
       padding: 4px ! important;
       margin: 4px ! important;
       border: 4px ridge aqua ! important; 
       width: 200px ! important;
     }

(This uncovers a few others bugs: typing in the form elements does strange 
things to the widths of their parents, scroll bars and various parts of the 
form elements are happily taking the style from the universal selector, and
other fun stuff. I'll file those separately.)

So: The INPUT element is not respecting 'width' correctly. 
Assignee: pierre → rods
Status: UNCONFIRMED → NEW
Component: Style System → HTML Form Controls
Ever confirmed: true
Summary: <select> element not rendering width in px's correctly. → <input type="text"> not respecting width correctly.
(Assignee)

Comment 3

19 years ago

*** This bug has been marked as a duplicate of 42521 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 4

19 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.