event.relatedNode is not set in mouseout events.

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: make, Assigned: hjtoi-bugzilla)

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview:
DOM2 specifies that event.relatedNode should be present in mouseover and 
mouseout events. This is not the case.

Steps to Reproduce:
View the webpage. Move the mouse and watch the statusbar text.

Actual Results:
event.relatedNode is undefined in mouseover events.

Expected Results:
event.relatedNode should contain the node which is about to be entered.

Build Date & Platform:
M16, WinNT 4
*** Bug 42828 has been marked as a duplicate of this bug. ***
Joki, I belive this belongs to you. Reassgning
Assignee: jst → joki
(Reporter)

Comment 3

18 years ago
Created attachment 10355 [details]
Two testcase - one for mouseover and one for mouseout
(Reporter)

Updated

18 years ago
Keywords: testcase

Comment 4

18 years ago
this doesn't appear to be reported elsewhere.  confirmed with 062808 build on NT
Status: UNCONFIRMED → NEW
Ever confirmed: true
Temporarily handling joki's bugs...
Status: NEW → ASSIGNED
I think this bug is invalid (maybe it became invalid because of changes in the 
DOM spec?). relatedNode property should appear only with mutation events, but 
mouse movement is not a mutation event. However, mouse events have a property 
relatedTarget, which is set correctly (you can test by changing relatedNode to 
relatedTarget in the URL).

Marking INVALID.

If you think I am in error, please reopen the bug and state why you think this 
is a valid bug. Thank you. 
Assignee: joki → heikki
Status: ASSIGNED → NEW
I do this all the time, NOW marking INVALID...
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

18 years ago
Correct. At the time, I reported the bug, I had only the candidate 
recommendation of DOM2. Between these versions relatedNode "mutated" into 
relatedTarget. Thanks.

Comment 9

18 years ago
Source code problem not ours. Marking as Verified.
Status: RESOLVED → VERIFIED
ksosez: If it is a source level problem it still must be verified. If you are
not qualified, someone who can code must look at the fix and say it is verified.
Component: DOM Level 2 → DOM Events

Comment 11

18 years ago
QA Contact Update
QA Contact: vidur → vladimire
You need to log in before you can comment on or make changes to this bug.