FF3: Javascript not executed properly (prior page load) resulting in blank page content

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
German
--
major
RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: Paul Piper, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

On my website www.bazaaria.com I am loading content dynamically. Once authenticated the Prototype API (Version "1.5.1.1") is used to search for modules on the page by their id ("gadid") and use the inner content as parameters for further Ajax.Request calls. 

This process seems to run smoothly on all browser and displays the correct content. But on the new FF3 the page itself stays empty and firebug exits with an error. I tested this various times and it seems as if the Prototype getElementById function does not find the relevant elements. However, once loaded I can manually run the script again and everythign works smoothly. 

This gets me to believe that JS is executed slightly before the page_load has ended, even though the onLoad event is used to trigger the script.



Reproducible: Always

Steps to Reproduce:
1. Open http://www.bazaaria.com in FF3 Beta
2. Click on Demo-Button
3. View blank page & compare to FF2 or other browser
Actual Results:  
In FF3: Page stays empty

Expected Results:  
page contains various modules that are dynamically added to the page content

Please try the steps above yourself by using the demo button. Though the webpage is german, the demo should be rather self-explanatory and authenticate you on the system...

This error occurs on both Windows and Macintosh platforms
(Reporter)

Comment 1

10 years ago
http://forums.mozillazine.org/viewtopic.php?p=3332941#3332941 --> we started a little discussion on the FF-Forums for this also...

Comment 2

10 years ago
For what it is worth the demo started for me but stops after some time with an error.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040907 Minefield/3.0pre ID:2008040907
(Reporter)

Comment 3

10 years ago
yes, that is related. The error is triggered as JS cannot find certain elements, which gave me to believe that js is executed shortly prior the actual content has been rendered. The script itself is loaded with the onLoad-Event...
Regression range is http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2007-01-31+22%3A00&maxdate=2007-02-01+23%3A00
Could be caused by Bug 357450 (?)
> Prototype API (Version "1.5.1.1")

That's known to be buggy wrt getElementsByClassName.  See http://ejohn.org/blog/getelementsbyclassname-pre-prototype-16/
Assignee: nobody → german
Status: UNCONFIRMED → NEW
Component: General → German
Ever confirmed: true
Product: Firefox → Tech Evangelism
QA Contact: general → german
/*  Prototype JavaScript framework, version 1.6.1

-> WFM.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.