Search engines dropdown blank if firefox install directory hidden

RESOLVED INVALID

Status

()

Firefox
Search
--
minor
RESOLVED INVALID
10 years ago
2 years ago

People

(Reporter: Owen S, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

After cleaning up my desktop I started Firefox 3b5 and found that all of the search engines (strictly the defaults in my case, since I hadn't added any) normally listed in the drop down.

Thinking about what I'd recently changed, I realized that the only modification I'd made was to the directory in which firefox is installed. I'm running as a limited user, so I have the program installed in C:\Documents and Settings\username\Desktop\firefox3b5 with a shortcut to the executable on the desktop as well. Given that the actual install directory is made redundant with the shortcut, I chose to apply the 'Hidden' attribute to the folder it's in.

I went back and removed the status and suddenly all the search engines had returned. I closed Firefox, ensured it wasn't running in Taskman, re-hid the directory and the searches were once again gone.

Reproducible: Always

Steps to Reproduce:
1. Close Firefox and locate the directory in which it's installed.
2. Set the 'hidden' attribute on the install directory either using the GUI or attrib.
3. Restart Firefox.
Actual Results:  
The search engines normally listed in the drop down are gone. Entering text and hitting 'Enter' causes no activity.

Expected Results:  
Perform a search using the previously selected search engine. Most software I've encountered would have just used an absolute path to the directory.

If it matters, the profile I'm using with Firefox was manually set up using the -p switch and is stored on a TrueCrypt volume. Obviously I always mount the volume before starting Firefox.
Yeah, we intentionally ignore engines that have the "hidden" attribute set, to be consistent with the old Firefox 2 code. I suppose there's no good reason to do that, but it does make it easy to temporarily disable loading of an engine when testing. I'm not sure whether we want to change this now...
Status: UNCONFIRMED → NEW
Ever confirmed: true
The default engines are now inside the omni.ja file (since bug 1162569), so this bug is no longer relevant.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.