bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Using a webmail client with LinkedIn's toolbar extension causes FF3b5 to crash [@ 0x10000 - xpc_CloneJSFunction]

RESOLVED DUPLICATE of bug 434673

Status

()

Core
XPConnect
--
critical
RESOLVED DUPLICATE of bug 434673
10 years ago
7 years ago

People

(Reporter: Warren Gee, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

FF3b5 crashes when I click on the "Older version" link in gmail. In general, using Yahoo, Hotmail, AOLMail, Gmail is okay without LinkedIn's toolbar installed. Once installed, FF is a lot less stable (crashes) when visiting one of these sites. 

Reproducible: Always

Steps to Reproduce:
1. Install FF3b5
2. Install LinkedIn's toolbar from: http://download.linkedin.com/desktop/firefox/companion/en/latest/bin/lincomp.xpi
3. Sign into your gmail.com account. I can get FF to crash when I have 0 or 50+ messages in my Inbox. I couldn't get it to crash with just 10.
4. Toggle back and forth between the "Newer version" and "Older version" of the client using the links in the top right corner
Actual Results:  
Eventually FF will crash after toggling about 6x

Expected Results:  
FF should not crash

Crash ID: 95bf8226-074e-11dd-8591-0013211cbf8a

LinkedIn's toolbar extension injects an icon into the DOM when viewing a web-based email. The purpose is to give the user a chance to hover over the icon to get more info about the sender of an email.

As mentioned above, this problem affects 4 webmail clients because they crash in different ways while the user is navigating through a webmail client.

Comment 1

10 years ago
Signature	@0x10000
UUID	95bf8226-074e-11dd-8591-0013211cbf8a
Time	2008-04-10 15:35:33-07:00
Uptime	47
Product	Firefox
Version	3.0b5
Build ID	2008032619
OS	Mac OS X
OS Version	10.4.11 8S2167
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 6
Crash Reason	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash Address	0x10000
Comments	I was switching to the "Older version" of the Gmail webmail service when it crashed.
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 		@0x10000 	
1 	XUL 	xpc_CloneJSFunction 	mozilla/js/src/xpconnect/src/xpcwrappednativeinfo.cpp:76
2 	XUL 	XPCWrapper::GetOrSetNativeProperty 	mozilla/js/src/xpconnect/src/XPCWrapper.cpp:1394
3 	XUL 	XPC_NW_GetOrSetProperty 	mozilla/js/src/xpconnect/src/XPCNativeWrapper.cpp:528
4 	libmozjs.dylib 	js_NativeGet 	mozilla/js/src/jsobj.c:3543
5 	libmozjs.dylib 	js_Interpret 	mozilla/js/src/jsinterp.c:4157
6 	libmozjs.dylib 	js_Invoke 	mozilla/js/src/jsinvoke.c:1303
7 	XUL 	nsXPCWrappedJSClass::CallMethod 	mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp:1475
8 	XUL 	nsXPCWrappedJS::CallMethod 	mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp:559
9 	XUL 	PrepareAndDispatch 	mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_unixish_x86.cpp:93
10 	XUL 	nsXPTCStubBase::Stub3 	mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_unixish_x86.cpp:1
Component: Extension Compatibility → XPConnect
Keywords: crash
Product: Firefox → Core
QA Contact: extension.compatibility → xpconnect
Summary: Using a webmail client with LinkedIn's toolbar extension causes FF3b5 to crash → Using a webmail client with LinkedIn's toolbar extension causes FF3b5 to crash [@ xpc_CloneJSFunction]
Version: unspecified → Trunk

Comment 2

10 years ago
(In reply to comment #1)
> Signature       @0x10000
> bp-95bf8226-074e-11dd-8591-0013211cbf8a
> Time    2008-04-10 15:35:33-07:00
> Uptime  47
> Product Firefox
> Version 3.0b5
> Build ID        2008032619

It sounds like something similar to bug 425596. Can you check with later builds?
(Reporter)

Comment 3

10 years ago
Crash ID: fc8ca5e1-0804-11dd-a1ea-0013211cbf8a

Still crashes with 2008041104 version of minefield.

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Using a webmail client with LinkedIn's toolbar extension causes FF3b5 to crash [@ xpc_CloneJSFunction] → Using a webmail client with LinkedIn's toolbar extension causes FF3b5 to crash [@ 0x10000 - xpc_CloneJSFunction]
Do we have any idea if this is a top crasher?
Flags: blocking1.9?

Comment 5

10 years ago
It doesn't look like a top-crasher to me, and I am not able to reproduce.
(Reporter)

Comment 6

10 years ago
I tried FF3b5 on Windows last night with the LinkedIn toolbar 3.1.0. It was stable but the InfoBox feature of the toolbar was not working. This morning I tried reproducing this bug on a colleague's MacBook Pro and managed to get FF to crash several times:

444c0740-0fd2-11dd-88a3-001cc45a2c28 Yahoo 
3b002af8-0fd1-11dd-8d4e-001cc45a2ce4 Hotmail
b94491c0-0fd0-11dd-9579-0013211cbf8a AOL
4824bfc0-0fcf-11dd-95c8-001321b13766 Gmail

It seems most stable with Gmail. Brian, did you get a chance to try reproducing this bug with either AOL's or Yahoo's webmail clients? Thanks.

Each of the webmail services have several versions of their clients. FF has a tendency to crash when toggling from one version to another. Some crashes occur as soon as I sign into my webmail account. 
(Reporter)

Comment 7

10 years ago
Let's try this. I created a test account on AOL. Same directions as before: on the Mac, install FF3b5 and install LinkedIn's toolbar. Go to aol.com and sign into the account "foobar314" using "password". Open up the welcome email. If that works try opening up the email using the Basic version of the client. There are links at the bottom of the page for switching versions.

Comment 8

10 years ago
Warren:  With a recent nightly build, I was able to reproduce all of your steps from comment #7 without crashing.  Can you please try a recent nightly as well, and see if this issue has been resolved for you?

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/?C=M;O=D
Warren, still crashing?  Trying to decide if this is a real blocker or not.  Speedy feedback really appreciated.  :)
(Reporter)

Comment 10

10 years ago
Sorry. I didn't know I was being watched. :)

The latest nightly, 2008042304, is rock solid. Thanks fellas.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 11

10 years ago
Can anybody tell me if this bug fix will be included in the RC1 release? TIA.

Updated

10 years ago
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 434673
(Assignee)

Updated

7 years ago
Crash Signature: [@ 0x10000 - xpc_CloneJSFunction]
You need to log in before you can comment on or make changes to this bug.