Does not pre-fill form

VERIFIED WORKSFORME

Status

()

Toolkit
Form Manager
P3
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Alek Jeziorek, Unassigned)

Tracking

({smoketest})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
1. go to Tasks | Privacy and Security | Form Manager | Interview
2. fill in your first and last name in the form
3. go to Tasks | Privacy and Security | Form Manager | Capture Data from Form
4. Quit and relaunch the browser
5. Tasks | Privacy and Security | Form Manager |Demonstration and click on 
amazon.com
6. Tasks | Privacy and Security | Form Manager | Prefill Form Safely

- what it should do is fill in your first and last name where it says to
-what really happens is that it says "There are no fields to be prefilled."
(Reporter)

Updated

18 years ago
Keywords: smoketest

Comment 1

18 years ago
Not dogfood, but marking [nsbeta2+]
Whiteboard: [nsbeta2+]

Comment 2

18 years ago
Fix checked in.  Error was in the wallet tables, namely FieldSchema.tbl.  Should 
be better now.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
still a problem using 2000.06.21.08 commercial opt bits. reopening. (followed
steps in smoketest B.24 on http://www.mozilla.org/quality/smoketests/ .)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 4

18 years ago
This is definitely working for me using mozilla debug build.  Could you please 
test it again.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

18 years ago
it now stops responding trying to pre-fill the form in on Win32 comm. 
2000-06-23-08-M17
(Reporter)

Comment 6

18 years ago
reopening
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 7

18 years ago
What do you mean by "it now stops responding trying to pre-fill the form"?  The 
original bug report said you get the message "There are no fields to be 
prefilled".  Are you now saying you are getting different symptoms.  If so, 
could you please be more specific.

Have you tried this with a virgin profile?  If not, please try that and tell me 
if you still see the same problem or if it then behaves differently.

Are you getting this failure with both the mozilla build and commercial build, 
or is it a commercial-build problem only?  Using the mozilla bild, I am unable 
to reproduce this problem.  It prefills just fine.

Sarah, are you able to reproduce the problem?
(Reporter)

Comment 8

18 years ago
What happens now instead of saying "There are no fields to be 
prefilled". It hangs and you have to press ctrl+alt+del to get the window to 
close or to be able to do anything. Yes it changed symptoms. I have tried it 
with a virgin profile and i can still reproduce it. I am pretty sure it is just 
a commercial problem but i will check now and update you.
i cannot reproduce this problem using mozilla 2000.06.28.08 on winnt, using a
fresh profile. (unable to test commercial bits at the moment due to
other...issues.)
(Reporter)

Comment 10

18 years ago
I can't reproduce this on mozilla build, but can on commercial. Can someone else 
try commercial to make sure? Thanks =)

Comment 11

18 years ago
OK, I just built a commercial tree and tried it.  And again it works fine for 
me.  :-/
i'm being blocked by that Activation bug
(http://bugscape.mcom.com/show_bug.cgi?id=1350), so i cannot test this on the
commercial bits.

Comment 13

18 years ago
I'm being blocked here by lack of definitive statements from Q/A.  I have not 
been able to reproduce this on either a commercial or a mozilla build.  Jazeriok 
reports that he can reproduce it on commercial but not mozilla.  Sarah reports 
that she cannot reproduce on mozilla but is currently unable to try it on 
commercial.  Until I get more info from Sarah, there is nothing further that I 
can do here.
Target Milestone: --- → M17

Updated

18 years ago
Status: REOPENED → ASSIGNED
(Reporter)

Comment 14

18 years ago
When testing on commercial try on windows 98. There is sometimes a difference 
between NT and win 98. I can still reproduce this everytime on Win32 comm. 
2000-07-05-08-M17

Comment 15

18 years ago
Sarah,

I really need for you to let me know if you can reproduce this problem.  I am 
unable to do so and I need to be able to determine if it is a real bug or some 
anomoly on Alek's machine.

Comment 16

18 years ago
Have not received independent verification from sairuh.  Until I do, I am 
assuming this is an anomoly on Alek's machine and marking this was works-for-me.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
hallo steve & alek --i've returned from vacation, and y'day i was swamped with
the email deluge. hence, i've only gotten to this till now. anyways... :-)

bugscape issue #1350 was finally fixed and verified only recently, so now am
testing using the commercial 2000.07.11.08-m17 [optimized] bits on my winNT box
(using a fresh profile, too!).

1. went to the Interview page and captured the form data (via Tasks > etc etc >
Capture Data found on Form).
2. i verified that the data was successfully captured by viewing the data in the
Stored Form Data dialog --it contained the sane field names of name.first and
name.last (tho' you need to click in the Values list box to see the actual value
--known bug).
3. went to the Demonstration page and selected the amazon.com sample form. i
then successfully prefilled the form, too (via Tasks > etc etc > Prefill Form
with Captured Data).

in light of this experience, i'm gonna verify this as WFM... Alek, have you
tried to reproduce your problem on another winNT and/or win98 machines (there
are more machines in the QA labs; claudius and jrgm might also have additional
machines for you to test on, too)?
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

18 years ago
I checked on another Win98 machine and it worked with build 2000-07-11-08-M17 
commercial
Adding keyword to bugs which already show a nsbeta2 triage value in the status 
whiteboard so the queries don't get screwed up.
Keywords: nsbeta2

Updated

10 years ago
Assignee: morse → nobody
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: bugzilla → form.manager
Target Milestone: M17 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.