Passwords with "@" sign will be send malformed. Password wont be usable with other browsers

RESOLVED DUPLICATE of bug 424524

Status

()

Firefox
Security
--
major
RESOLVED DUPLICATE of bug 424524
10 years ago
10 years ago

People

(Reporter: Falko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

I just noticed that I can't log in to some websites with my normal username/password combination. In my password I use a combination of letters, numbers and the "@" sign. I checked these websites with Safari (MacOS X) and Firefox 2 and was able to log in. But not with Firefox 3 beta. Then I changed a password with Firefox 3 beta to my normal password (with the @-sign) and thus wasn't able to login from the other browsers. 
So I assume that Firefox 3 beta is sending some other character then the "@" sign when it comes to password fields.
It seems to be OK for normal text fields as I can see the "@" sign normally and it's normally recognized as an "@" sign by the server (for instance GoogleMail address fields).

Reproducible: Always

Steps to Reproduce:
1. Have an account on any website with an "@" sign in the password (created with other than Firefox 3 )
2. Try to login with Firefox 3
3. You wont be able to login, due to wrong password
Actual Results:  
I wont be able to login to these sites, due to wrong password given.

Expected Results:  
I should be logged in, because I'm 100% sure I typed the password correct. And it works in other Browsers.

I use Firefox 3 beta on MacOS X 10.5.2
(Reporter)

Comment 1

10 years ago
I just figured out that this has something to do with the way the text is entered into the password field of the site.
When I type it with the keyboard, the "@"-sign seems to be converted to something else so the server wont recognize it as "@" sign.

When I type the password in clear text into a clear text field, then copy it to clipboard and paste it into the password field it will work.

So the bug seems to be the input mechanism for password fields.

I use an english version of Firefox 3beta and a german version of MacOS X.
(Reporter)

Comment 2

10 years ago
I just checked the same version of Firefox 3 beta5 on Ubuntu Linux. It doesn't seem to have this problem at all. 
So it's seems to me that this is MacOS X specific.
(Reporter)

Comment 3

10 years ago
I just checked this Firefox3 beta5 on another Mac with MacOS 10.4.11 and it has this problem as well. So it's not a fault of my single machine and not a bug of Firefox3 in conjunction with MacOS X 10.5 (Leopard)

Comment 4

10 years ago
Using: Fx3b5 as well as Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008041004 Minefield/3.0pre

I was not able to reproduce the problem. I tried a dummy gmail account on a Vista machine on Fx3b5, and I changed my password to something containing the @ character. Then I went to my 10.4.11 machine using Fx3b5 and latest trunk, and I had no problem logging in.
(Reporter)

Comment 5

10 years ago
I just tried it on a PowerBook G4 under MacOS X 10.5.2 Leopard with the en_US version:

Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

This also has the problem. The MacOS X itself is the german version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424524
You need to log in before you can comment on or make changes to this bug.