Select All in mail thread pane crashes

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
P3
critical
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Phil Peterson, Assigned: David Hyatt)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
Using 2000-06-16-08 commercial M17 build on NT

1. Open mail inbox
2. Click in thread pane
3. Press Ctrl+A
4. Boom

Stack trace from talkback points to the tree widget, so assigning to hyatt, 
cc'ing putterman

   nsTreeRowGroupFrame::FindNextRowContent                                                    
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeRowGroupFrame.cpp, line 
672]     
   nsTreeFrame::GetNextItem                                                    
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeFrame.cpp, line 672]     
   nsTreeBoxObject::GetNextItem                                                    
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeBoxObject.cpp, line 140]     
   nsXULTreeElement::SelectItemRange                                                    
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULTreeElement.cpp, line 315]     
   nsXULTreeElement::SelectAll                                                    
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULTreeElement.cpp, line 351]     
   XULTreeElementSelectAll                                                    
[d:\builds\seamonkey\mozilla\rdf\content\src\nsJSXULTreeElement.cpp, line 483]     
   js_Invoke                                                    
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 687]     
   js_Interpret                                                    
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2491]     
   js_Invoke                                                    
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 703]     
   js_InternalInvoke                                                    
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 776]     
   JS_CallFunctionValue                                                    
[d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2803]     
   nsJSContext::CallEventHandler                                                    
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 792]     
   nsJSEventListener::HandleEvent                                                    
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 155]     
   nsEventListenerManager::HandleEventSubType                                                    
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
755]     
   nsEventListenerManager::HandleEvent                                                    
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
1579]     
   nsXULElement::HandleDOMEvent                                                    
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3419]     
   nsXULKeyListenerImpl::HandleEventUsingKeyset                                                    
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULKeyListener.cpp, line 1599]     
   nsXULKeyListenerImpl::LocateAndExecuteKeyBinding                                                   
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULKeyListener.cpp, line 1248]     
   nsXULKeyListenerImpl::DoKey                                                    
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULKeyListener.cpp, line 533]     
   nsXULKeyListenerImpl::KeyPress                                                    
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULKeyListener.cpp, line 474]     
   nsEventListenerManager::HandleEvent                                                    
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
1081]     
   nsXULDocument::HandleDOMEvent
(Reporter)

Comment 1

18 years ago
Added crash and nsbeta2 keywords
Keywords: crash, nsbeta2

Comment 2

18 years ago
*** Bug 42866 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
Bug 42558 marked as duplicate of this bug

Comment 4

18 years ago
*** Bug 42558 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
nsbeta2+
Whiteboard: [nsbeta2+]
(Assignee)

Comment 6

18 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
pratik - pls verify on all platforms - Thanks.
QA Contact: lchiang → pratikd

Comment 8

18 years ago
Using Build Id: 2000-06-20-08 M17, for MAC, Linux and NT4
Verified: Fixed
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.