visit_count=0 for revisited links that open in a separate frame

RESOLVED DUPLICATE of bug 424110

Status

()

--
minor
RESOLVED DUPLICATE of bug 424110
11 years ago
10 years ago

People

(Reporter: em3ryguy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

most links on that page open in the right hand frame not in a separate window. if you visit it twice then relead the entire page (http://sfbay.craigslist.org/forums/?forumID=96) then the link color shows 'unvisited'. sqlite extension shows that visit_count in places.sqlite is zero. this happens in safe mode so its not an extension. it only affects links that open in a frame on that page.

Reproducible: Always

Steps to Reproduce:
1.find a reply to any thread. click on it. (link will change color)
2.click on it again.(color will not change)
3.reload tab (color will change back to 'unvisited')
Actual Results:  
color will change back to 'unvisited'

Expected Results:  
color should show 'visited'.

please dont tell me that its something simple like i dont have visited color set right or i have 'keep history for' set to zero. i have been on the forums discussing this with people who know what they are doing and they couldnt fix it.

its very hard to use that forum if i cant tell which links are new. i normally just click on all the links then reload to see if there are any new posts. 

btw, it would be extemely convenient if i could just hit a button and cause all links on the page to turn color. there are a hundred posts on that page and clicking every one is a major hassle. it didnt used to be so bad since i didnt have to wait for each post to load before hitting the next one. but now i do and i am on dial up.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041308 Minefield/3.0pre

I went to http://sfbay.craigslist.org/forums/?forumID=96 , clicked twice on a link with the title  AutoCAD is GREAT , then I reloaded the tab but the color stayed dark blue (visited). So I can't seem to reproduce this.
(Reporter)

Comment 2

11 years ago
link with the title? title of what? did the link open in the frame on the right?
(Reporter)

Comment 3

11 years ago
"autocad is great' was the title of the link. 

i downloaded the newest version of minefield and it doesnt do it so i guess it got corrected somewhere between my original download of firefox beta and now. i would have downloaded minefield before i posted this bug report but it was blocked.  i only just figured out how to unblock it.  

Comment 4

11 years ago
This looks to be the same as bug 424110.  There you can find an attached zip file, that demonstrates the problem.

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424110
You need to log in before you can comment on or make changes to this bug.