Bookmarking tabs as "/." (slash dot) into "Unsorted Bookmarks" creates invisible folder

RESOLVED DUPLICATE of bug 426475

Status

()

RESOLVED DUPLICATE of bug 426475
11 years ago
9 years ago

People

(Reporter: alexander, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

When I bookmark several tabs with Ctrl-Shift-D as "/." in "Unsorted Bookmarks" in Firefox 3.0b5, the resulting folder is invisible in the bookmarks sidebar and bookmarks manager.

It seems to exist though, since the Awesome Bar finds those bookmarks, and I can see their titles in places.sqlite.

Reproducible: Always

Steps to Reproduce:
1. Open several tabs, press Ctrl-Shift-D
2. Assign the title /. as the folder name and pick "Unsorted Bookmarks" as the target
3. Add Bookmarks, then open bookmarks sidebar or manager
Actual Results:  
The created folder does not show up. The bookmarks can be found through the Awesome Bar.

A trace of the created folder may be visible when you bring up the Ctrl-Shift-D dialog again: the target folder dropdown list contains a nameless folder.
most likely a dupe of bug 426475
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 426475
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.