The default bug view has changed. See this FAQ.

when browser.startup.page=3 show appropriate warnings on quit/restart

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: Roman R., Unassigned)

Tracking

({regression, useless-UI})

Trunk
regression, useless-UI
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008041206 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008041206 Minefield/3.0pre

Recent attempts to fix the multiple tabs close warning issues have led to another problem.

I've configured Firefox to "show my windows and tabs from last time" when it starts. Yet, when I try to close Firefox, I am now asked if I want to save windows and tabs. So, now Firefox acts like someone with memory problems (besides leaks) and/or trust issues. I was specific and certain when I "told" it to "show my windows and tabs from last time" when it starts, and I don't want to be asked this question again. Well, maybe when I set an option "I am not sure anymore" or something like that, current behavior would be justified.

The situation seems simple to me: 
- if said "show tabs and windows from last time", do it without confirming every time.
- if I said "warm me before closing multiple tabs/windows", do it.

Reproducible: Always
(Reporter)

Updated

9 years ago
Version: unspecified → Trunk

Comment 1

9 years ago
I always have problems with this feature. For me it doesn't even ask me at all it just closes the window whether or not I have tabs open. Without saving them or asking me if I want to save.

Do you think this might be a Windows Vista only problem?


-Mike
(Reporter)

Comment 2

9 years ago
What build do you have? This has been "fixed" very recently (bug 419009). And you have to set certain preferences.
(Reporter)

Comment 3

9 years ago
My tabs and windows have been saved and reopened (I set this in the Main tab in the pref dialog). My issue now is with the text and logic of the current warning dialog. It should simply ask if I really want to close 120 tabs that I have open :)

Comment 4

9 years ago
QUOTE:
What build do you have?
________________________________

I'm using the nightly build which seems to be having problems.



-Mike
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041308 Minefield/3.0pre

Confirming, because of superfluous "Quit" dialog when session restore is already the expected behaviour. This regressed on 10 Apr 2008, possibly from Bug 419009.
Blocks: 419009
Status: UNCONFIRMED → NEW
Component: General → Session Restore
Ever confirmed: true
QA Contact: general → session.restore
Keywords: regression

Updated

9 years ago
Component: Session Restore → General
OS: Windows Vista → All
QA Contact: session.restore → general
Hardware: PC → All
This was an intentional change from bug 419009. You can disable the quit prompt by disabling the "warn me when closing multiple tabs" pref, but that also disables the prompt when you close a window with multiple tabs.

To get the old behavior, you need to set your preferences as follows:

browser.startup.page = 3 ("save my windows and tabs from last time")
browser.tabs.warnOnClose = true (warn when closing more than one tab)
browser.warnOnQuit = false (override warnOnClose when quitting - don't warn)

The third pref is key - it also has no UI.
Summary: Firefox doesn't trust the "show my windows and tabs from last time" setting → "Show my windows and tabs from last time" no longer disables the Quit/Restart prompt
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Beltzner: did you mean WONTFIX? This isn't INVALID.
Status: RESOLVED → REOPENED
Flags: blocking-firefox3?
Resolution: INVALID → ---
Its INVALID since its intended behaviour.  But if WONTFIX is going to stick, I'll do that.  Reasoning is in the original bug.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Flags: blocking-firefox3?
Resolution: --- → WONTFIX
Actually, I never meant to mark this INVALID. And especially since the quit confirmation dialog now contains useless-ui (a "Quit" button that doesn't actually not save and quit) I don't think this is WONTFIX.

Apologies to mconnor, I think I led him astray with the accidental INVALID marking. Reopening.

(Also morphing the summary; I don't think that the restart warning really applies here in the same way, as that warning kind of supersedes the tabs/quit warnings and is meant to remind that session restore isn't 100% dataloss-free.)
Status: RESOLVED → REOPENED
Keywords: useless-UI
Resolution: WONTFIX → ---
Summary: "Show my windows and tabs from last time" no longer disables the Quit/Restart prompt → when browser.startup.page=3 show appropriate warnings on quit/restart

Comment 10

9 years ago
(In reply to comment #9)
> (a "Quit" button that doesn't actually not save and quit)

That'd be bug 385582 of which this bug is a DUPE (or now vice versa).
Blocks: 442736

Updated

7 years ago
Blocks: 565517
No longer blocks: 565517

Comment 11

6 years ago
invalid due to Bug 592822?

Comment 12

5 years ago
Wanted behavior was achieved with Bug 629485
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.