CSS and packaging changes (/toolkit) for APNG throbber

RESOLVED FIXED in Firefox 3

Status

()

Firefox
Theme
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Dolske, Assigned: Dolske)

Tracking

Trunk
Firefox 3
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
Created attachment 315343 [details] [diff] [review]
Patch v.1

Followup to bug 421595. Changes in /toolkit to use the new APNG throbbers.

* Does not delete old throbber packaging, since mailnewscalendar are still using Throbber-small.gif.
* Does not change /toolkit/crashreporter usage, since I assume that doesn't support APNG.
* Fixes uses of "loading_16.gif" in Pinstripe, which is no longer packaged and thus broken.
Attachment #315343 - Flags: ui-review?(beltzner)
Attachment #315343 - Flags: review?(beltzner)
(Assignee)

Comment 1

10 years ago
[The changes to /toolkit/themes/pinstripe/* are no longer needed, since they were done in bug 428764.]
Depends on: 428759

Comment 2

10 years ago
Will GTK and Windows have a different throbber? If so you'll need to provide an override in jar.mn for the throbber in Gnomestripe and you'll also need to provide new files that Gnomestripe doesn't have to override Winstripe's (extensions/update.css and update/update.css in mozapps)

Comment 3

10 years ago
Actually, if the throbbers will be at the same relative locations you don't need those new CSS files, just a jar.mn change.
(Assignee)

Comment 4

10 years ago
All 3 themes already have their own throbbers packaged, and all are chrome://global/skin/icons/loading_16.png [There's even a Vista Aero specific one, although currently it's just a duplicate of the non-Aero version.]

This bug is about changing usage of the old throbber chrome:// URIs to the new one. The old throbbers are still packaged, because I didn't want to break extensions that might be using them so late.

Comment 5

10 years ago
Oh I see, its in icons/ now. I was looking at throbber/.
Comment on attachment 315343 [details] [diff] [review]
Patch v.1

uir+a=beltzner
Attachment #315343 - Flags: ui-review?(beltzner)
Attachment #315343 - Flags: ui-review+
Attachment #315343 - Flags: review?(beltzner)
Attachment #315343 - Flags: review+
(Assignee)

Comment 7

10 years ago
Checking in toolkit/themes/gnomestripe/mozapps/extensions/extensions.css;
  new revision: 1.22; previous revision: 1.21
Checking in toolkit/themes/gnomestripe/mozapps/update/updates.css;
  new revision: 1.2; previous revision: 1.1
Checking in toolkit/themes/winstripe/mozapps/extensions/extensions.css;
  new revision: 1.56; previous revision: 1.55
Checking in toolkit/themes/winstripe/mozapps/extensions/update.css;
  new revision: 1.6; previous revision: 1.5
Checking in toolkit/themes/winstripe/mozapps/update/update.css;
  new revision: 1.8; previous revision: 1.7
Checking in toolkit/themes/winstripe/mozapps/update/updates.css;
  new revision: 1.7; previous revision: 1.6
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.