Keywords saved in "Unsorted Bookmarks" by using "Add a Keyword for this Search..." are not visible

VERIFIED FIXED in Firefox 3

Status

()

Firefox
Bookmarks & History
--
major
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: whimboo, Assigned: mak)

Tracking

({dataloss, regression})

Trunk
Firefox 3
dataloss, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by 426475])

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008041104 Minefield/3.0pre ID:2008041104

Using "Add a Keyword for this Search..." to save a search as a keyword will hide the bookmark if it is saved into "Unsorted Bookmarks". You will not be able to change it by using the Library. It will only show up when doing a search in the Awesome bar. Saving the keyword to any other folder still works. So something is wrong with "Unsorted Bookmarks".

Steps:
1. Open following site: http://mxr.mozilla.org/mozilla/
2. Open the context menu of the first textbox and choose "Add a Keyword for this Search..."
3. Name it "Mxr Search" and give it the keyword "mxr"
4. Expand the folder list and select "Unsorted Bookmarks"
5. Save keyword

Now open the Library and choose "Unsorted Bookmarks". There is no bookmark with the given name visible. If you do a search in the location bar and type "Mxr Search" the bookmark will show up. But you don't have a change to edit or delete this bookmark. It's doomed in places.sqlite.
Flags: blocking-firefox3?
(Reporter)

Updated

10 years ago
Keywords: regression
(Assignee)

Comment 2

10 years ago
i've tried now and i see the bookmark in unsorted bookmarks folder, with keyword associated... and keyword works... so WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041506 Minefield/3.0pre
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-firefox3? → blocking-firefox3-
Resolution: --- → WORKSFORME

Comment 3

10 years ago
Not WFM with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008041604 Minefield/3.0pre. And look at the list of suggestions for the folder to put the bookmark into: the suggestions are blank.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

10 years ago
Flags: blocking-firefox3- → blocking-firefox3?
(Assignee)

Comment 4

10 years ago
(In reply to comment #3)
> Not WFM with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre)
> Gecko/2008041604 Minefield/3.0pre. 

So, linux only?

> And look at the list of suggestions for the
> folder to put the bookmark into: the suggestions are blank.

that is a different bug, bug 426475 exactly
Bug still present in
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041608 Minefield/3.0pre
No, it's not still present in Windows. At least, I don't see it.
OS: All → Linux
Is it possible that this is actually just a dupe of bug 426475? This is definitely WFM, I've tried it on a bunch of sites, a bunch of different ways.
It fails always here, in my normal profile and in a new profile.

OS: Linux → All
(In reply to comment #8)
> It fails always here, in my normal profile and in a new profile.
>
I assume because it is impossible to select the Unsorted Bookmarks folder.
Sometimes but not always I find the keyword bookmarks on the bottom of the bookmarks menu instead.  

(Assignee)

Comment 10

10 years ago
so we should first fix bug 426475 and see if that will solve this.
Problem is that the bookmark is created as a child of unsorted bookmark shortcut, rather than as a child of the real unsorted folder.
Assignee: nobody → mak77
Status: REOPENED → NEW
Depends on: 426475
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
Flags: blocking-firefox3? → blocking-firefox3+
Whiteboard: [fixed by 426475?]
Flags: blocking-firefox3+ → blocking-firefox3-
The empty "Create in" field was already present on 8 Jan 2008 probably in the range of comment 1, but I didn't pay attention to it.
Flags: blocking-firefox3- → blocking-firefox3?
Flags: blocking-firefox3?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041722 Minefield/3.0pre

This appears to be fixed now.
(Assignee)

Comment 13

10 years ago
Aleksej, can you check the next nightly on Linux and mark fixed eventually?

Comment 14

10 years ago
Seems to work with the (hourly?) Linux-i686 build 2008041803 from <http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fx-linux-tbox-trunk/>.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by 426475?] → [fixed by 426475]

Comment 15

10 years ago
(In reply to comment #13)
> and mark fixed eventually?

Or maybe duplicate?
verified with: 
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008041804 Minefield/3.0pre
Status: RESOLVED → VERIFIED
(Reporter)

Updated

10 years ago
Target Milestone: --- → Firefox 3
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.