leaking NSAutoreleasePool object in insertText

RESOLVED FIXED in mozilla1.9

Status

()

Core
Widget: Cocoa
--
critical
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

({memory-leak, regression})

Trunk
mozilla1.9
x86
Mac OS X
memory-leak, regression
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 315580 [details] [diff] [review]
Patch v1.0

This is my fault.

NSAutoreleasePool is now leaking at every enter key pressing!
And that is not need here, because that was already created by event loop. So, we don't need to create that ourselves. (The code was written by me, sorry)

This leaking is occurred on chatzilla at very very many time. So, we must fix this on Gecko1.9. They should be just removed.
Flags: blocking1.9?
Attachment #315580 - Flags: review?(joshmoz)

Updated

10 years ago
Attachment #315580 - Flags: review?(joshmoz) → review+
(Assignee)

Updated

10 years ago
Attachment #315580 - Flags: superreview?(vladimir)
Flags: blocking1.9? → blocking1.9+
Whiteboard: [needs review vlad]
Attachment #315580 - Flags: superreview?(vladimir) → superreview+
Comment on attachment 315580 [details] [diff] [review]
Patch v1.0

Let's take this. This leaks the memory every Enter key pressing.
Attachment #315580 - Flags: approval1.9?
Comment on attachment 315580 [details] [diff] [review]
Patch v1.0

a1.9=beltzner
Attachment #315580 - Flags: approval1.9? → approval1.9+
-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [needs review vlad]
You need to log in before you can comment on or make changes to this bug.