If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

warnings in test_saved_searches.js

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
spotted by sdwilsh:

WARNING: history observers should not get OnItemChanged, but should get the corresponding history notifications instead: file /Users/dietrich/moz/trunk/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp, line 2875
WARNING: history observers should not get OnItemChanged, but should get the corresponding history notifications instead: file /Users/dietrich/moz/trunk/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp, line 2875
WARNING: history observers should not get OnItemChanged, but should get the corresponding history notifications instead: file /Users/dietrich/moz/trunk/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp, line 2875
WARNING: Attempting to register an observer twice!: file /Users/dietrich/moz/trunk/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp, line 3851
WARNING: Attempting to register an observer twice!: file /Users/dietrich/moz/trunk/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp, line 3830
WARNING: Attempting to register an observer twice!: file /Users/dietrich/moz/trunk/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp, line 3830
WARNING: Attempting to register an observer twice!: file /Users/dietrich/moz/trunk/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp, line 3830
WARNING: history observers should not get OnItemChanged, but should get the corresponding history notifications instead: file /Users/dietrich/moz/trunk/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp, line 2875
WARNING: history observers should not get OnItemChanged, but should get the corresponding history notifications instead: file /Users/dietrich/moz/trunk/mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp, line 2875

Updated

8 years ago
Duplicate of this bug: 443225
"WARNING: Attempting to register an observer twice!"

this is quite common, iirc actually this is caused by calling Refresh on an history QueryResultNode, it will call fillChildren and that tries to add the node to the list of history observers. The addition does not happen because we check duplicates before allowing to register a node twice. I'm not sure if this warning makes sense since we already check for duplicates, and what happens is pretty natural (fillChildren does not know if it is called for the first time or by refresh).

"WARNING: history observers should not get OnItemChanged, but should get the
corresponding history notifications instead"
this is handled with refresh for query QUERY_UPDATE_COMPLEX_WITH_BOOKMARKS, but actually could be notified also to QUERY_TYPE_BOOKMARKS, so i'm not sure this warning is saying anything useful.

Personally i'd remove both.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
I think I've recently (4.0) fixed both.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.