Thunderbird address book CSV export discards newline/CRLF in notes field

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
11 years ago
11 years ago

People

(Reporter: m0zillabugs, Unassigned)

Tracking

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: 2.0.0.12 (20080213)

In Thunderbird's Address Book it is common to put line breaks into the Notes field.  When you export with Tools > Export > Comma separated, it replaces all line breaks with spaces.

Correct behaviour should be to include the line break within a quoted string - this behaviour should allow the Notes to be imported into Excel or Outlook or Windows Contacts or wherever, without loss of formatting (or indeed loss of meaning, if the line breaks are meaningful in the notes).

Bug 182128 describes a similar problem for Notes within Thunderbird and states that that has been fixed; but this present bug report concerns Address Book exporting.


Reproducible: Always

Steps to Reproduce:
1. Create an address book entry; in the Notes field enter "Foo" <return> "Bar"
2. export as CSV

Actual Results:  
Voila!  The return has disappeared.

Expected Results:  
Encapsulate the Notes field in double quotes and include a return.
(In reply to comment #0)
> Bug 182128 describes a similar problem for Notes within Thunderbird and states
> that that has been fixed; but this present bug report concerns Address Book
> exporting.

Bug 182128 has fixed this problem in the Address Book Notes field of Thunderbird - but only for the next major release. Bug 182128 was fixed after Thunderbird 2.0 was released. The Thunderbird 2.x releases are for security and stability releases only.

Whilst I could dupe this, I'm marking as WONTFIX as we won't put that fix onto the 2.x releases.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
Version: unspecified → 2.0
You need to log in before you can comment on or make changes to this bug.