All users were logged out of Bugzilla on October 13th, 2018

Do not accumulate blinking events when browser is suspended

RESOLVED FIXED

Status

()

RESOLVED FIXED
11 years ago
6 years ago

People

(Reporter: sylvain.pasche, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
I noticed something strange this morning when resuming my computer. I had a page open with some blinking text. For about 10 seconds, the browser was blinking text elements very fast consuming lots of CPU.
My understanding is that the blink timer accumulated blink events while it was stopped and dispatches them when it is unsuspended.

This can be simulated with something like:

1) open: 
data:text/html,<div style="text-decoration: blink; font-size: 20em">blink</div>
2) kill -STOP {pid}; sleep {some_seconds}; kill -CONT {pid}
3) notice the fast blinking for a few seconds. Then normal blinking continues.

Comment 1

11 years ago
See also bug 431492. (I'd merge them, but: this is a bug, not an enhancement, and I can't change the severity.)

Comment 2

11 years ago
s/merge them/mark that as duplicate/.
(Reporter)

Comment 3

11 years ago
Yes, that's a duplicate. I've adjusted the severity.
Severity: enhancement → normal
(Reporter)

Updated

11 years ago
Duplicate of this bug: 431492

Comment 5

6 years ago
Support for blink effect was dropped in bug 857820.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.