simplified chinese names in mail folder

VERIFIED DUPLICATE of bug 39757

Status

MailNews Core
Internationalization
P3
normal
VERIFIED DUPLICATE of bug 39757
18 years ago
10 years ago

People

(Reporter: Anders Helmersson, Assigned: scottputterman)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (Win98; U)
BuildID:    2000061408

Simplified chinese names in mail folders does not work correctly. When naming a 
new or renaming an old folder, the folder appears with subfolders. When leaving 
mozilla the program hangs. 

Reproducible: Always
Steps to Reproduce:
1. File -> New -> Folder
2. Enter a name in simplfied chinese using MS IME in New Folder Box
3. Click OK

Actual Results:  A folder with the chinese name is created. However, it contains 
empty subfolders with the same names as the top level folders.

When quitting mozilla, the mail window dissapears but the program seems to hang. 
Has to be ended by the task manager.


When mozilla is restarted, the created mail folder does not exist.

Expected Results:  An empty  folder with a simplified chinese name should have 
been created. It should contain no subfolders.

Renaming an existing folder to a simplified chinese name causes a similar 
problem. 

Chinese names in bookmarks work ok.

Comment 1

18 years ago
I'm guessing this is for a local folder, not an IMAP folder, since IMAP is not 
mentioned.. Not sure who did local folder creation. Was it Jeff?
Assignee: bienvenu → putterman
Component: Mail Database → Internationalization

Comment 2

18 years ago
This may be a dup of 39757 - local folder name support should be non OS 
dependent.
Was this tested with Simplified Chinese or used US system?
(Reporter)

Comment 3

18 years ago
Yes, it seems to be a dup of 39757.
It was tested with Swedish system?

Comment 4

18 years ago
qa contact to momoi to verify if indeed a dup
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: lchiang → momoi
(Assignee)

Comment 5

18 years ago
marking as a dup of 39757

*** This bug has been marked as a duplicate of 39757 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
This is indeed a duplicate of Bug 39757. When that bug is fixed,
we should be able to do what the bug reporter is trying to do
without a problem.
Marking it verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.