Status

Firefox for Android Graveyard
General
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: Aleks Totic, Assigned: mfinkle)

Tracking

Trunk
x86
Windows XP

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: 

I've refactored the awesomeBar into an overlay. I tried to minimize the differences. The basic idea was:
- move all awesomeBar commands & UI into an overlay
- remove all references to LocationBar from browser code
  to do this, i had to create new events by progressController, endNetwork/startNetwork/locationUpdate

This will allow us to overlay different awesomeBar implementations. I did not know how to make svn spit out the diffs for files not under svn control, so I checked in awesomeToolbar.xul/js.


Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 315905 [details] [diff] [review]
Patch to refactor out the awesome bar

This takes out Bookmarks & LocationBar out of browser.js/xul
The code moves to awesomeToolbar.js/xul, which are already checked in.
Assignee: nobody → mark.finkle
Looks like this patch no longer applies?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

10 years ago
Some of this was already done before we moved to Hg. Let's file new bugs for any future refactors
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
yeah, this is old and awesome bar is working great.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.