unable to create test plans in fresh install - "Plan undefined" / internal error

RESOLVED DUPLICATE of bug 409309

Status

--
critical
RESOLVED DUPLICATE of bug 409309
11 years ago
11 years ago

People

(Reporter: reg.mozilla, Assigned: gregaryh)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_5_2; en-us) AppleWebKit/525.13 (KHTML, like Gecko) Version/3.1 Safari/525.13
Build Identifier: bugzilla-3.0.2.tar.gz & testopia-2.0-BETA1.tar.gz

A fresh install of testopia-2.0-BETA1 will not create test plans.  

There were no errors in the install the patch ran perfectly.  

The only variation from the requirements (http://wiki.mozilla.org/Testopia:README) is that I have json version	1.2.1 installed (rather than 1.14)

The pages load and look to work, but new plan data does not save.

Also, the product version list is not displayed in the drop down.

Reproducible: Always

Steps to Reproduce:
1. Install bugzilla and confirm it works
2. Install testopia and get no errors
3. Try to create a test plan and cry

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 409309
(Reporter)

Comment 2

11 years ago
Thanks Vance, but bug 409309 refers to Testopia 1.3 BETA2 and not testopia-2.0-BETA1

Can I infer that the issue is with JSON, and that only 1.14 is known to work reliably and thus I need to downgrade from 1.2.1?

Comment 3

11 years ago
(In reply to comment #2)
> Thanks Vance, but bug 409309 refers to Testopia 1.3 BETA2 and not
> testopia-2.0-BETA1
> 
> Can I infer that the issue is with JSON, and that only 1.14 is known to work
> reliably and thus I need to downgrade from 1.2.1?

*All* versions of testopia are broken with the newer JSON. Yes, you need to downgrade your JSON.
You need to log in before you can comment on or make changes to this bug.