"Assertion failure: top < ss->printer->script->depth" with "for", trap()

VERIFIED FIXED

Status

()

Core
JavaScript Engine
--
critical
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
x86
Mac OS X
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Pasting this into the js shell:

function f() { for(; 1; ) { } }
trap(f, 0, "");
f

triggers:

Assertion failure: top < ss->printer->script->depth, at jsopcode.c:882

Comment 1

10 years ago
Does the patch in bug 422137 resolve this?

Comment 2

10 years ago
The patch in bug 422137 does -not- resolve this.  I -think- the issue is to do with some confusion over a source note referring to what has now been rewritten as a JSOP_TRAP.

Comment 3

10 years ago
The decompiler is confused by the use of source-notes here.  We are definitely not doing the right thing in the JSOP_TRAP case for bytecodes accompanied by src-notes (JSOP_NOP, in this case).  Is Igor's suggestion from bug 422137 comment 50 more expedient than more whack-a-mole here?

Comment 4

10 years ago
This is fixed by my WIP patch from bug 422137.

Updated

10 years ago
Depends on: 422137

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: in-testsuite?
Resolution: --- → FIXED

Comment 5

10 years ago
Created attachment 317756 [details]
js1_5/extensions/regress-429264.js

I'll check in when the tree reopens

Comment 6

10 years ago
/cvsroot/mozilla/js/tests/js1_5/extensions/regress-429264.js,v  <--  regress-429264.js
initial revision: 1.1

Note to self: When run on x86_64 in the test framework this exits with signal 6 or 7 but I can't reproduce it using jsDriver or just plain vanilla js.
Flags: in-testsuite?
Flags: in-testsuite+
Flags: in-litmus-
Bug on file for apparent 64-bit-only bug leading to crash? What signals are 6 and 7 according to `man signal` on that system?

/be

Comment 8

10 years ago
re bug, not yet. I want to reboot and see if my flakiness goes away after a full rm objdirs and complete rebuilt.

kill -l  6) SIGABRT      7) SIGBUS 

Comment 9

10 years ago
v 1.9.0. the signal issues on centos5 x86_64 are gone.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.