Attached fail sending to Exchange 2007 clients is failing

RESOLVED INCOMPLETE

Status

Thunderbird
General
--
major
RESOLVED INCOMPLETE
10 years ago
9 years ago

People

(Reporter: Rain Nahkur, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; WOW64; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; InfoPath.2)
Build Identifier: All Versions

If sending .doc or .xls attachments to Exchange 2007 clients, Exchange server sends back NDR "#554 5.6.0 Corrupt message content" and refuses to receive message. Helps deleting mimetypes.rdf file under user profile directory, but for some reason the problem would occur after some time again. 

Reproducible: Always

Steps to Reproduce:
1. Write new mail addressed to some Exchange 2007 user
2. Attach a file
3. Send
4. Wait for NDR :)
Actual Results:  
NDR:

#554 5.6.0 STOREDRV.Deliver; Corrupt message content ##rfc822;


Seems that Mozilla Thunderbird sends attachment with wrong MIME type and Exchange's store service refuses to receive attachments with incorrect MIME types.
Do you have an actual message that causes a failure?

Comment 2

9 years ago
Rain got any messages as example which cause such failure?

Comment 3

9 years ago
Closing Incomplete for lack of answers.

Feel free to reopen if you can provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.