bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Deleting many bookmarks in Bookmark Manager extremely slow

RESOLVED DUPLICATE of bug 432706

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 432706
10 years ago
9 years ago

People

(Reporter: Martin Post, Unassigned)

Tracking

({perf})

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

I import all bookmarks from an external DB once a week, so I have around 4,000 bookmarks in one folder. Deleting them to repeat the procedure takes very long in 3.0b5. After selecting 1000 bookmarks and pressing the Delete key, it took ca. 80 seconds until the system responded again - something that took 3 seconds in version 2.0.

Reproducible: Always

Steps to Reproduce:
1. Put 1,000 or more bookmarks in one folder of the Bookmark library.
2. Select this folder in the Bookmark Library, then select all 2,000 Bookmarks. 
3. Press "Delete".
4. Wait until the procedure is completed. On my system (a fast MacBook Pro), this took minutes.
(Again, these bookmarks are imported regularly from an external DB, so they all end up in one folder - splitting is not an option.)
Actual Results:  
FF takes extremely long to delete the bookmarks from the Library.

Expected Results:  
FF 3.0 should be able to delete large numbers of bookmarks (1,000 - 5,000) in a reasonable amount of time (a few sconds), just as FF 2.0 did.

You guys rock - this is my only prob with 3.0 so far. Thanks.

Comment 1

10 years ago
This seems to be a duplicate of bug 428459.
(Reporter)

Comment 2

10 years ago
> This seems to be a duplicate of bug 428459.

Not sure - the report for 428459 describes hanging and partial completion ("First level bookmarks deleted. Subfolders not deleted.") Over here, deleting thousands of bookmarks is just *very* slow, but eventually finished. However, if you kill FF after hitting delete, there are no changes at all, i.e. on restart all bookmarks are still there. So deletion is either completed or doesn't occur at all.

BTW, I also tried to move imported bookmarks into a subfolder, which is extremely slow as well - moving 200 bookmarks takes almost a minute. Not sure if this is the same bug.

Comment 3

10 years ago
The reporter of bug 428459 added in a comment that firefox was able to delete the bookmarks after some minutes. Comment 3 and 5 only mention the bad performance of deleting many bookmarks.

> BTW, I also tried to move imported bookmarks into a subfolder, which is
> extremely slow as well - moving 200 bookmarks takes almost a minute. Not sure
> if this is the same bug.

Bug 420199 describes bad performance when moving many bookmarks.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
Keywords: perf
Whiteboard: [3.1]

Comment 4

10 years ago
a more recent report, but that one is confirmed (NEW)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 432706
Whiteboard: [3.1]
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.