After SeaMonkey Window has closed, clicking on the SeaMonkey icon doesn't give any effect earlier than passes about 40 seconds.

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Vladimir, Unassigned)

Tracking

SeaMonkey 1.1 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.8.1.12) Gecko/20080201 SeaMonkey/1.1.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.8.1.12) Gecko/20080201 SeaMonkey/1.1.8

After closing SeaMonkey window clicking the SeaMonkey icon results changing the mouse cursor like if SeaMonkey is starting, but after waiting a long time nothing happens.
If I click SeaMonkey icon again after waiting about 40 seconds one more time, it is starting normally.
It looks like it must pass any time while some "processes" will finished before it becomes possible to start application again.
It is bad behavior because, for example, Internet Explorer doesn't do like that!

Reproducible: Always

Steps to Reproduce:
1. Start SeaMonkey, may be open any web site.
2. Close SeaMonkey window.
3. Immediately try to start SeaMonkey again.
Actual Results:  
Mouse cursor becomes change arrow to watch, like if SeaMonkey is starting, but SeaMonkey does not start.

Expected Results:  
SeaMonkey must start independent of how much time passed from closing its window last time. It must not wait of "complete finish" a previous session.

SeaMonkey have option "stay in memory... to quick start" - something like this.
Its icon always stays in taskbar. (by the way in menu "options" this flag never shows like "selected").
(Reporter)

Updated

10 years ago
Version: unspecified → SeaMonkey 1.1 Branch
(In reply to comment #0)
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.8.1.12)
> Gecko/20080201 SeaMonkey/1.1.8

Can you reproduce with SeaMonkey v1.1.9 ?

> SeaMonkey have option "stay in memory... to quick start" - something like this.

Does it happen too without this option ?

> Its icon always stays in taskbar. (by the way in menu "options" this flag never
> shows like "selected").

Please, file separate bugs for separates issues.
Internet Explorer is not comparable: most of the IE code is loaded with Windows and never goes away.

Even after the last SeaMonkey window closes, it may take some time (minutes) until the application has closed everything neatly, and finally exits. How long exactly may depend on things like, among others, the number of open tabs. From my experience, 40 seconds doesn't seem excessive.

Since when starting SeaMonkey, it will check if it is already running, and open whatever you ask it to open in the existing instance if there is one, and since a SeaMonkey which is "busy closing down" stops listening to messages from other instances of itself, if you try to reopen it while it is still busy closing down, you may get the infamous "already running but not responding" popup. The workaround is to open some task manager (on Windows, the Task Manager, accessible from the Ctrl-Alt-Del popup; on Linux, KDE System Guard or GNOME System Monitor, etc.) then check the list of Processes (not Applications), sort the list on the process name, and wait until "seamonkey.exe" (Windows), "seamonkey-bin" (Linux), "seamonkey.app" (Mac), etc., has disappeared from its alphabetical place.

This is not a bug, it is how things were meant to be => INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.