Adblocker: navigation menus of Spiegel Online are blocked

RESOLVED FIXED

Status

Camino Graveyard
Annoyance Blocking
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: CFV, Assigned: Smokey Ardisson (offline for a while; not following bugs - do not email))

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de; rv:1.8.1.14) Gecko/20080409 Camino/1.6 (MultiLang) (like Firefox/2.0.0.14)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de; rv:1.8.1.14) Gecko/20080409 Camino/1.6 (MultiLang) (like Firefox/2.0.0.14)

See summary. Spiegel Online is one of Germany's most important news sites.

Reproducible: Always

Steps to Reproduce:
1. Turn on adblocking
2. Visit www.spiegel.de

Actual Results:  
Top Menu is blocked

Expected Results:  
Show menus, still hide ads
This seems to work OK for me; can you be more specific about the problem (or attach a screenshot)?

Comment 2

10 years ago
Yeah, I see that as well, but only with branch; trunk builds work. There is some background-flash ad at top and right. When blocked, it turns into a black rectangle.

Comment 3

10 years ago
Got it with trunk builds as well.
The top ad I see is loaded into an absolute positioned div [1] with black background. That div is injected with javascript, then filled with flash stuff.
But that div is not blocker

There is also a webbug -inline img-, sized to the same height as that ad-div. The webbug is used to push the masthead down, and makes space for the ad at the top. The webbug is also blocked by ad-blocking.css (and doesn't push the masthead down). Thus, the mashead is covered.

All this courtesy of adserv.quality-channel.de


[1] <div id="flashlayer" style="padding: 0px; position: absolute; top: 0px; left: 0px; z-index: 1; height: 110px; width: 796px; background-color: rgb(0, 0, 0);">
(Reporter)

Comment 4

10 years ago
philippe describes very well what I see. I just realized that it seems to be covered, not blocked, too, when I tried it again and the menu was visible for a fraction of a second. I can't technically describe what happens there, hopefully that's okay!
philippe sees this, so NEW.  From the description I'm not sure what we can do, but we need to try to do something.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

10 years ago
Created attachment 316460 [details]
Screenshots showing the problem

The attached screenshots show the described problem.
If you disable JavaScript the site displays just perfect.
Blocking scripting for adserv.quality-channel.de didn't work for me.

This ad seems to be very new, as I visit this site on a daily basis. Unfortunately spiegel.de is one of the German bookmarks in the news section. If we can't fix this, we should consider removing it in a future release of Camino or the ML build.
Ah, I was looking for the wrong menu ;)

Blocking 

div[id="spColumnAd"]

seems to fix it for me.
Assignee: nobody → alqahira
Depends on: 421850

Comment 8

10 years ago
Works for me, too.
FIXED on trunk by checkin of bug 421850.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.