If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

domain name not shown correctly

RESOLVED WORKSFORME

Status

()

Firefox
Address Bar
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Samuël, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; nl; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; nl; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

In nl.wikipedia.org I entered the name Ararat. In the adress bar it is shown the wrong way.

Reproducible: Always

Steps to Reproduce:
1.Go to nl.wikipedia.org and type Ararat
2.Use the third link
Actual Results:  
Firefox goes to http://nl.wikipedia.org/wiki/Ararat_%28berg%29

Expected Results:  
It should show as http://nl.wikipedia.org/wiki/Ararat_(berg)

Comment 1

10 years ago
(In reply to comment #0)
> Actual Results:  
> Firefox goes to http://nl.wikipedia.org/wiki/Ararat_%28berg%29
> 
> Expected Results:  
> It should show as http://nl.wikipedia.org/wiki/Ararat_(berg)
> 

Thank you for the report. I don't believe this is a bug. Look at the source code of the wikipedia page you are referring to. Search for the "Ararat (berg)" link and look at the src attribute of the link. This link just points to wiki/Ararat_%28berg%29.

The usage of %28 and %29 for the ( and ) characters is known as url encoding. You can find more about that subject on http://en.wikipedia.org/wiki/Urlencode

I believe this issue can be closed.

Comment 2

10 years ago
I'm sure it can be closed - for example, running your mouse over the url-encoded links above automatically generates the proper link.
(Reporter)

Comment 3

10 years ago
I just installed Opera. Opera shows it like it should be. So it is a bug. And yes, it is true that with Firefox you go to the correct page. But it has to be shown correctly in the address bar. With Firefox is doesn't, with Opera it does. And I do prefer Firefox.

Comment 4

9 years ago
Firefox 3 does this fine.

Going to this link in FF3:
http://nl.wikipedia.org/wiki/Ararat_%28berg%29
Shows the decoded URL as:
http://nl.wikipedia.org/wiki/Ararat_(berg)

There's quite a few bug reports mentioning this change; not sure which to dupe to, off hand.  Closing as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.