CSS tables with fixed background images handle scroll incorrectly

RESOLVED FIXED

Status

()

RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: bugzilla, Assigned: roc)

Tracking

({regression, testcase})

Trunk
x86
All
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041707 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041707 Minefield/3.0pre

This is very likely closely related to bug #416735, which is listed as fixed. The main difference is that in my usage, I expect a fixed table image to stay put when I scroll text from a TD element on top of it, as it worked in FF2. For example, something like:

table {border-width:1px; border-style:solid; border-color:0000aa; background-color: 000011; background-image:test.jpg; background-repeat:no-repeat; background-attachment: fixed;}
td {background:transparent;border-collapse: collapse}

...should have a static background image as part of the outer table structure while TD text long enough to go outside the table's boundaries should scroll over it. The example page I listed doesn't behave as expected.

Reproducible: Always

Steps to Reproduce:
Load a sample page consisting of code similar to this:


<html>

<head>

<style type="text/css">

table {border-width:1px; border-style:solid; border-color:0000aa; background-color: 000011; background-image:test.jpg; background-repeat:no-repeat; background-attachment: fixed;}

td {background:transparent;border-collapse: collapse}

</style>

</head>

<body>

<table>
  <tr>
    <td>

     (enough text to scroll off screen, or limit table size to get vertical scrollbar)

    </td>
  </tr>
</table>

</body>

</html>
Actual Results:  
Background image scrolls with text.

Expected Results:  
Background image should stay fixed relative to table.

Default theme, works fine in FF2 builds, has never worked correctly in IE6. I'm submitting as a minor bug even though I know of no workaround, because it's really not a big deal--just slightly annoying.
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk

Comment 1

11 years ago
Created attachment 316496 [details]
Testcase #1

Comment 2

11 years ago
Regression range: 2006-02-05-04 -- 2006-02-06-05
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-02-05+03%3A00&maxdate=2006-02-06+06%3A00&cvsroot=%2Fcvsroot

Bug 324883?
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, testcase
OS: Windows XP → All
I'm surprised 416735 didn't fix this.
Assignee: nobody → roc
Created attachment 316500 [details] [diff] [review]
fix

This was fixed but it regressed probably due to a merge issue. I wish C++ had 'override' so we could catch these bugs. Anyway, here's the trivial fix.
Attachment #316500 - Flags: superreview?(mats.palmgren)
Attachment #316500 - Flags: review?(mats.palmgren)
Layout regression with a trivial safe patch.
Flags: blocking1.9?
Whiteboard: [needs review]

Comment 6

11 years ago
Comment on attachment 316500 [details] [diff] [review]
fix

r+sr=mats with s/aAncestorFrame/rootMover/ on the comment
Attachment #316500 - Flags: superreview?(mats.palmgren)
Attachment #316500 - Flags: superreview+
Attachment #316500 - Flags: review?(mats.palmgren)
Attachment #316500 - Flags: review+

Updated

11 years ago
Whiteboard: [needs review]
Comment on attachment 316500 [details] [diff] [review]
fix

trivial fix for a layout/rendering regression
Attachment #316500 - Flags: approval1.9?
Whiteboard: [needs approval]
Comment on attachment 316500 [details] [diff] [review]
fix

a1.9+=damons
Attachment #316500 - Flags: approval1.9? → approval1.9+
Whiteboard: [needs approval] → [needs landing]
checked in
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: [needs landing]
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.