BeOS needs PNG 8-bit alpha transparency

VERIFIED FIXED

Status

()

Core
ImageLib
P3
normal
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: Chris Hill, Assigned: Matthew Zahorik)

Tracking

Trunk
x86
BeOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
nsImageBeOS needs some minor modifications to support 8-bit masks needed for PNG 
support
(Reporter)

Comment 1

18 years ago
Created attachment 10340 [details] [diff] [review]
proposed patch

Comment 2

18 years ago
Confirming, adding patch keyword, changing component to imagelib
Status: UNCONFIRMED → NEW
Component: Compositor → ImageLib
Ever confirmed: true
Keywords: patch

Comment 3

18 years ago
I am trying to get this bug to the right person.
Assignee: kmcclusk → maz

Comment 4

18 years ago
As mozilla for Be isn't properly loading at this point, I'm going to throw this 
to ASSIGNED and make it my responsibility to check/fix/apply patch when we have 
the port back up to parity and *displaying* images again.
Status: NEW → ASSIGNED
(Assignee)

Comment 5

17 years ago
Okay, Mozilla is loading well enough to test this bug.  (pulling network pages
starting today)

The gfx and widget libraries are entirely rewritten, so this may be a moot bug.

I'll have someone test for proper 8-bit PNG transparency and will either retire
the bug or re-submit a new patch off current sources.

I'm marrying in 8 days, so I'm a bit too swamped to check it myself (:

- Matt

Comment 6

17 years ago
If you need to implement the 8bit alpha compositor (the DrawComposited family of
functions) separately on BeOS then please DO NOT make the same mistake as the
present implementations for Windows and Unix.
See Bug 51179 for what's apparently wrong with those implementations.

Comment 7

16 years ago
This seems to be working now.  I was able to view an 8-bit alpha transpaency PNG image at http://www.libpng.org/pub/png   

Should this be marked resolved?

RESOLVED WORKSFORME
I think Pavlov fixed this with his other libimg2 cleanups.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.