[MLK] Various objects leaked viewing tables

VERIFIED DUPLICATE of bug 17390

Status

()

Core
XUL
P2
normal
VERIFIED DUPLICATE of bug 17390
18 years ago
18 years ago

People

(Reporter: rusty.lynch, Assigned: Stuart Parmenter)

Tracking

({memory-leak})

Trunk
x86
All
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

18 years ago
I've been experimenting with my current Linux build, and have found that we are
leaking all kinds of objects when viewing a large html table, and if I scroll
through the whole page then we leak many times more objects.  One interesting
note is that this is only true for 'mozilla-bin'. Doing the same test of
'viewer' results in only a small amount of leaks.

I've captured some bloatview logs (sorted for the largest leaks on top.)  For my
test case, I am viewing a huge html table generated by bloatblame.

My test case is:
  * http://www.linux86.com/testcases/bigtable.html

this is a bloatview log for viewing bigtable without scrolling: (~ 0.6M leaked)
  * http://www.linux86.com/bloatview/nonscrolling_table_bloatview.txt

this is a bloatview log for viewing bigtable and slowly scrolling up and down
the page: ( ~ 4.4M leaked )
  * http://www.linux86.com/bloatview/scrolling_table_bloatview.txt

here is the same test case repeated twice by reloading: (~ 8.2M leaked )
  * http://www.linux86.com/bloatview/refresh_scrolling_table_bloatview.txt

and here is what it looks like if 'viewer' is used: (~ 2k leaked )
  * http://www.linux86.com/bloatview/viewer_scrolling_table_bloatview.txt
(Reporter)

Comment 1

18 years ago
Adding mlk keyword.
Keywords: mlk

Comment 2

18 years ago
additional notes:
1. Comment out this line: 
http://lxr.mozilla.org/seamonkey/source/rdf/content/src/nsXULKeyListener.cpp#366
   the leaks associated with loading the page will all be gone. 

2. Seems to me that additional leaks during scrolling only happens when you 
scroll the page by dragging the button on the scroll bar. if you scroll the 
page by clicking on the scroll bar, there's no leak. 

Comment 3

18 years ago
Changing the component from tables to RDF based on the last comments. 
Assignee: karnaze → waterson
Component: HTMLTables → RDF
QA Contact: desale → tever

Comment 4

18 years ago
-> XUL
Component: RDF → XP Toolkit/Widgets

Comment 5

18 years ago
no, really -> XUL!
Assignee: waterson → trudelle
QA Contact: tever → jrgm

Comment 6

18 years ago
->Pavlov (no, really)
Assignee: trudelle → pavlov

Updated

18 years ago
Keywords: nsbeta3

Comment 7

18 years ago
nsbeta3+, p2 for M18, cc hyatt
Priority: P3 → P2
Whiteboard: [nsbeta3+]
Target Milestone: --- → M18
(Assignee)

Comment 8

18 years ago
adding ccs
(Assignee)

Comment 9

18 years ago
this appears to have been fixed by dbaron.  marking as a duplicate of his bug

*** This bug has been marked as a duplicate of 17390 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 10

18 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.