html 4.01 transitional and table background

RESOLVED DUPLICATE of bug 108466

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 108466
10 years ago
10 years ago

People

(Reporter: ferraro.francesco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

There's some problems to see a simple page with a table and three different color background. I've check the code with W3C Markup Validation Service. You can download the source of the file and two screenshots from this link via SendSpace

Reproducible: Always

Steps to Reproduce:
1.Download this archive via SendSpace http://www.sendspace.com/file/28ja60 
2.Open the page in archive with Firefox
3.
Actual Results:  
See three missing background color

Expected Results:  
See all teh background colors in the cell table

Archive with the example page. 

SO: Windows Vista SP1 Home Premium Italian. 
Theme: Vista-Aero
Extension: - AutoFormer
- Ctrl Tab Preview
- Italian Dictionary
- Fast Dial
- Free Download Manager Plug-in
- gTranslate
- Hide Menubar
- IE Tab
- Mouse Gesture
- Tabs Open Relative
- Talkback
- Undo Closed Tabs Button
- United States English Dictionary
Please attach a minimized testcase.
Do you get the same problem with Firefox 3 beta 5 or later ?
Does it make a difference if you run Firefox in the firefox safemode ?
(Reporter)

Comment 2

10 years ago
How can I add a testcase via bugzilla? I've add a testcase in the sendspace link yet...
(Reporter)

Comment 3

10 years ago
In the safemode the problem persist, in the FF3 Beta 5 I see the three background (red, green and blu) but I can't see the 9 white blocks and a wrong background page. IE7 and Opera 9.27 (both in last stable release open this page correctly)
(Reporter)

Comment 4

10 years ago
This is the code of simple testcase writed with Dreamweaver CS3 build 3481.

------------ Start Source Code----------------
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<title>Untitled Document</title>
<body bgcolor="#999999">
<table width="850" border="0" align="center" cellpadding="0" cellspacing="0">
  <tr>
    <td height="170" bgcolor="#000000"></td>
    <td bgcolor="#000000"></td>
    <td bgcolor="#000000"></td>
    <td bgcolor="#000000"></td>
    <td bgcolor="#000000"></td>
  </tr>
  <tr>
    <td height="34"></td>
    <td rowspan="5" bgcolor="ff3333"></td>
    <td rowspan="5" bgcolor="#FFFFFF"></td>
    <td rowspan="5" bgcolor="#FFFFFF"></td>
    <td rowspan="5" bgcolor="#FFFFFF"></td>
  </tr>
  <tr>
    <td height="34"></td>
  </tr>
  <tr>
    <td height="34"></td>
  </tr>
  <tr>
    <td height="34"></td>
  </tr>
  <tr>
    <td height="34"></td>
  </tr>
  <tr>
    <td height="34"></td>
    <td rowspan="5" bgcolor="00994d"></td>
    <td rowspan="5" bgcolor="#FFFFFF"></td>
    <td rowspan="5" bgcolor="#FFFFFF"></td>
    <td rowspan="5" bgcolor="#FFFFFF"></td>
  </tr>
  <tr>
    <td height="34"></td>
  </tr>
  <tr>
    <td height="34"></td>
  </tr>
  <tr>
    <td height="34"></td>
  </tr>
  <tr>
    <td height="34"></td>
  </tr>
  <tr>
    <td height="34"></td>
    <td rowspan="5" bgcolor="4166b0"></td>
    <td rowspan="5" bgcolor="#FFFFFF"></td>
    <td rowspan="5" bgcolor="#FFFFFF"></td>
    <td rowspan="5" bgcolor="#FFFFFF"></td>
  </tr>
  <tr>
    <td height="34"></td>
  </tr>
  <tr>
    <td height="34"></td>
  </tr>
  <tr>
    <td height="34"></td>
  </tr>
  <tr>
    <td height="34"></td>
  </tr>
</table>
</body>
</html>
------------------ EndSource Code -----------


This is a screenshot of W3C Validation
http://img254.imageshack.us/img254/3422/w3cvalidatoroksh3.png

And this is a screenshot of FF 2.0.0.14
http://img142.imageshack.us/img142/3527/firefoxcv6.png

Comment 5

10 years ago
DUPEME to bug 108466
Without the # before the color value in standards compliance mode the colors won't show. They will only if the page is in quirks mode.
See http://paste.css-standards.org/39226/view for the example with # included.
(Reporter)

Comment 6

10 years ago
The problem on FF2.0.0.14 is fix but not in FF3b5...
Created attachment 316494 [details]
Testcase from the reporter

oh boy, how difficult is it to just scroll through a bug report to find :
"Add an attachment  (proposed patch, testcase, etc.) " ?
Pasting such long source makes bugs less readable
This is indeed just invalid because of standards compliance mode triggered and the # are missing

marking as dupe of bug 108466
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 108466
You need to log in before you can comment on or make changes to this bug.