Page Load Error page Try Again button disabled after connection disconnect

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: nightstalkerz, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041807 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041807 Minefield/3.0pre

The Try Again button becomes disabled if it is pressed and the Page Load Error page appears again. This is caused by a connection being dropped.


Reproducible: Always

Steps to Reproduce:
1. Have a network intensive application in the background (e.g. bittorrent)
2. Wait until the network is unstable
3. Visit a page
4. Page Load Error page should appear
5. Click on Try Again button
6. If network is unstable, Page Load Error page should appear again but with the Try Again button disabled

Actual Results:  
Try Again button is disabled.

Expected Results:  
Try Again button is not disabled.

You still can refresh the page by using the refresh button or any other means but inexperienced users will not know about this.

Comment 1

10 years ago
Are you sure that you did not press the Stop button (or hit Escape) while waiting for the connection timeout?

I'm asking because there is a known problem that the button is not re-enabled in this case (bug 410397).
Version: unspecified → 3.0 Branch
(Reporter)

Comment 2

10 years ago
The only button I pressed was the Try Again button.

Comment 3

10 years ago
Well, I cannot reproduce this on a current build of Firefox 3.
(Reporter)

Comment 4

10 years ago
I will try again on the latest nightlies. It's been 2 months so it might have been fixed but I will check.

Comment 5

10 years ago
results? (FF 3.0.2 is out)

Comment 6

10 years ago
=> WFM based on comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

10 years ago
> Comment #5
Still occurring with 3.0.5 and latest nightly.
(Reporter)

Comment 9

10 years ago
Forgot to mention this also occurs in Firefox 2.0.20 so its not a regression.

Comment 10

10 years ago
> Forgot to mention this also occurs in Firefox 2.0.20 so its not a regression.

same profile, or different?


strange.  It's also been WFM (try again never goes disabled) on my home vista which as recently as today.  I've had problems resulting in frequent page load errors, which appears to be slow DNS** from my ISP or home network. I'm not sure what to conclude why my experience is different from nightstalkerz.  Ropening.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081222 Shiretoko/3.1b3pre

**dnslookup report

Name: "bugzilla.mozilla.org"
Error: No such host is known.  (11001)
Time: 12055.607 ms
Alternate 2 (W2KPro and up):
Error: This operation returned because the timeout period expired.
 (1460)
Time: 12058.540 ms (In reply to comment #9)
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 11

10 years ago
All are on new profiles.

Comment 12

9 years ago
WFM - 3.0.12/linux - 
Can you please try the simpler case of disconnecting your network - unplugging - turning off your router or whatever to see if this same problem occurs?
(Reporter)

Comment 13

9 years ago
Disconnecting the network doesn't work as the offline mode will be activated.

This can probably be marked as invalid/cannot reproduce since no one else can reproduce it.

Comment 14

9 years ago
per comment 13
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.