Closed Bug 429813 Opened 12 years ago Closed 12 years ago

MineField hangs for no apparent reason with high

Categories

(Firefox :: General, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 429903

People

(Reporter: cmhofman, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008041804 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008041804 Minefield/3.0pre

In the latest nightlies MineField sometimes hangs for no apparent reason. Just browsing. CPU usage goes way up and the app becomes unresponsive. 

Reproducible: Always

Steps to Reproduce:
1. Browse for a while
2. 
3.
Actual Results:  
Minefield becomes unresponsive and CPU usage goes up to nearly 100%.
This is a sample I took when the reported hang occurred.
Yes, I was getting the same thing.  Reverting to cvs update from Gecko/2008041307 Minefield/3.0pre fixes stops this behaviour.

The problem always happens with the URL below - I believe flash has something to do with it.

Just enter the website and click a few links - FF will either hang as page changes, or it will become unresponsive if you leave to go to another URL:

http://www.speedmaster-mission.net/

Nick
Forgot, I am on x86 Linux base.

Nick
OK, with latest build today:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008042009 Minefield/3.0pre

I have found through experiment that NoScript v1.6 causes (my/the) issue.  If I disable it, I do not see the hanging behaviour.  Also just disabling NoScript Flash block option doesn't help either.

Enable NoScript again, and the URL I referenced above hangs FF in a matter of seconds.

Nick
Raised to critical, as it makes MineField unusable. It also happens very often now. Changed hardware and OS to All, as this apparently also happens on Linux. 


I don't have NoScript, so that's not the cause.
Severity: normal → critical
OS: Mac OS X → All
Hardware: Macintosh → All
I'm having very similar-sounding issues with Nightly builds on Windows XP, since around the 15th (+/- 2 days) and I do have AdBlock+ 0.7.5.4 installed, but not NoScript.

This may be a duplicate of Bug 429903 (or vice versa).
(In reply to comment #6)
> I'm having very similar-sounding issues with Nightly builds on Windows XP,
> since around the 15th (+/- 2 days) and I do have AdBlock+ 0.7.5.4 installed,
> but not NoScript.
> 
> This may be a duplicate of Bug 429903 (or vice versa).
> 

Yes, the sample looks the same. It's a deadlock after Flash_EnforceLocalSecurity. I also have AdBlock+, but i don't see anything related to it in the sample.  
Marking as a dupe: the stacks look similar, similar STR, and same regression range.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429903
You need to log in before you can comment on or make changes to this bug.