copying text from some pages inserts garbage characters between the characters on the page

VERIFIED INCOMPLETE

Status

()

--
critical
VERIFIED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: monty, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

After selecting and copy text from various pages including the one with the URL specified above, garbage characters appear in the copied text between each character that was copied from the page(s).

Reproducible: Always

Steps to Reproduce:
1.Visit the URL specified above
2.Click and drag to select some text from the article
3.Copy the text
3.Paste the text into a new window in Eudora or TextWrangler
4.Observe garbage characters

Comment 1

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008041816 Minefield/3.0pre

Works fine for me.  I loaded http://online.wsj.com/article/SB120835576139919511.html and copied the entire page (Cmd+A, Cmd+C) to TextWrangler.  I didn't see any garbage characters.
This is a mass search for bugs that are in the Firefox General component, are
UNCO, and have not been changed for 800 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile,
http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you
still see the bug, please update this bug. If the issue is gone, please set the
resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

8 years ago
The problem still occurs.

I copied some text from
http://www.nytimes.com/2010/11/07/magazine/07Winger-t.html

Here is an octal dump showing that nulls were inserted after each character.

0000320   015 015 000 043 000 040 000 124 000 150 000 145 000 040 000 116
          \r  \r  \0   #  \0      \0   T  \0   h  \0   e  \0      \0   N
0000340   000 145 000 167 000 040 000 131 000 157 000 162 000 153 000 040
          \0   e  \0   w  \0      \0   Y  \0   o  \0   r  \0   k  \0    
0000360   000 124 000 151 000 155 000 145 000 163 000 040 000 122 000 145
          \0   T  \0   i  \0   m  \0   e  \0   s  \0      \0   R  \0   e
0000400   000 160 000 162 000 151 000 156 000 164 000 163 000 015 000 124
          \0   p  \0   r  \0   i  \0   n  \0   t  \0   s  \0  \r  \0   T
0000420   000 150 000 151 000 163 000 040 000 143 000 157 000 160 000 171
          \0   h  \0   i  \0   s  \0      \0   c  \0   o  \0   p  \0   y
0000440   000 040 000 151 000 163 000 040 000 146 000 157 000 162 000 040
          \0      \0   i  \0   s  \0      \0   f  \0   o  \0   r  \0    
0000460   000 171 000 157 000 165 000 162 000 040 000 160 000 145 000 162
          \0   y  \0   o  \0   u  \0   r  \0      \0   p  \0   e  \0   r
0000500   000 163 000 157 000 156 000 141 000 154 000 054 000 040 000 156
          \0   s  \0   o  \0   n  \0   a  \0   l  \0   ,  \0      \0   n
0000520   000 157 000 156 000 143 000 157 000 155 000 155 000 145 000 162
          \0   o  \0   n  \0   c  \0   o  \0   m  \0   m  \0   e  \0   r
0000540   000 143 000 151 000 141 000 154 000 040 000 165 000 163 000 145
          \0   c  \0   i  \0   a  \0   l  \0      \0   u  \0   s  \0   e
0000560   000 040 000 157 000 156 000 154 000 171 000 056 000 040 000 131
          \0      \0   o  \0   n  \0   l  \0   y  \0   .  \0      \0   Y
0000600   000 157 000 165 000 040 000 143 000 141 000 156 000 040 000 157
          \0   o  \0   u  \0      \0   c  \0   a  \0   n  \0      \0   o
0000620   000 162 000 144 000 145 000 162 000 040 000 160 000 162 000 145
          \0   r  \0   d  \0   e  \0   r  \0      \0   p  \0   r  \0   e
0000640   000 163 000 145 000 156 000 164 000 141 000 164 000 151 000 157
          \0   s  \0   e  \0   n  \0   t  \0   a  \0   t  \0   i  \0   o
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

8 years ago
I tested as you requested and posted a reply.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.