Old bookmarks file does not migrate properly

VERIFIED WONTFIX

Status

P3
normal
VERIFIED WONTFIX
19 years ago
14 years ago

People

(Reporter: xalkina, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Created a bookmark file with a previous version of mozilla and copied it for
reference. Downloading and installing a new nightly build, usually means
removing .mozilla. When I copied back the bookmarks file, mozilla does not show
any bug in the personal bookmarks in the corresponding bar above the main
window. The bookmarks are there in the sidebar's pane, but are not clickable
(ie, bothing happens when you do click on them...).
They're only accesible from the bookmarks menu and the bookmarks option of the
personal bar.
Using linux/2000061809

Comment 1

19 years ago
Reporter, could you please attach the bookmark file you mention (or a subset
of it) to this bug, or tell us with which mozilla build you created it?
Thanks!
(Reporter)

Comment 2

19 years ago
Attaching file now, do not remember mozilla build that created it --sorry.
(Reporter)

Comment 3

19 years ago
Created attachment 10362 [details]
testcase

Comment 4

19 years ago
It seems like the bookmark file format has changed, although no bookmarks are
lost when migrating to the newer format, the "Set as Personal Toolbar Folder"
setting does not migrate properly (from an earlier Mozilla build at least).
As reported earlier, when accessing the testcase via the sidebar, no browser
navigation occurs, but the console outputs:
BrowserAppCore is not initialised

40819 and this one are both caused by Mozilla's inability to auto-fix bookmark
files that weren't migrated properly.

On Win32 070420 the testcase bookmarks are accessible via the sidebar but the
"Set as Personal Toolbar" setting also wasn't migrated.

Confirming & updating summary to more accurately reflect the problem. Marking OS
as ALL.

Tested on Win32 070420 and an optimized Linux CVS build from 7/4.

Can someone test this on a Mac?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Summary: No bookmarks shown on personal bookmarks using old bookmarks file → Old bookmarks file does not migrate properly

Updated

19 years ago
Blocks: 27226

Comment 5

18 years ago
m18
Target Milestone: --- → M18

Comment 6

18 years ago
Reassigning 79 Bookmarks bugs to Ben.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → ben
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
Netscape Nav Triage Team: marking wontfix

Comment 8

18 years ago
VERIFIED WontFix
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.