Phrase Search broken on Wiki

RESOLVED WORKSFORME

Status

Websites
wiki.mozilla.org
RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: Hb, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
Searching for phrases with enclosing the terms in double quotes [1] doesn't work on wiki.mozilla.org. All pages are given back which have at least one word of the phrase. This leave the search worthless.


[1]
http://wiki.mozilla.org/Help:Searching#phrase
Component: other.mozilla.org → wiki.mozilla.org
"Works for me", as they say. 

Could you give an example of a search which isn't working for you? If there is nothing available at the search target then, iirc, it should split the terms and find them individually (just as Google, etc, do) - are you certain that the phrase target you are looking for actually exists?
Flags: needinfo?(hb)
(Reporter)

Comment 2

5 years ago
WFM now. The search string -- "Folder Pane bug 446306" -- gives only one result while the string -- Folder Pane bug 446306 -- gives more.

My former test case search is shown in the URL of this bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(hb)
Resolution: --- → WORKSFORME
ahah. I can now tell you why that may fail: "bug 446306" may not be on the wiki as actual text, albeit visible as such to you as a user. If you edit the page (ie what the search is searching against) it is probably a linking template such as "{{bug|446306}}" thus when the search function is looking for the absolute text "Folder Pane bug 446306" it can't find it - because it doesn't actually exist!

'bug 446306' (without quotes) is sufficient to go direct to the page and ignores the wiki markup.
You need to log in before you can comment on or make changes to this bug.