Closed Bug 429998 Opened 12 years ago Closed 10 years ago

r6025 Pure virtual function call

Categories

(Firefox :: General, defect)

3.0 Branch
x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: crzftx, Unassigned)

Details

(Keywords: stackwanted, Whiteboard: [CLOSEME 2010-09-15])

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

I downloaded a .torrent, and it opened in uTorrent, like it is supposed to.  At this point Firefox was no longer the active window.  I was doing nothing at all with Firefox when the error happened.  It closed Firefox.  I had just (within 5 seconds) completed a download.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
I really don't know how to reproduce the error, I've downloaded .torrent's before, never seeing this error.
Actual Results:  
Firefox crashed

Expected Results:  
I didn't expect anything to be going on with Firefox at the time of the error

A few other people have received the same error, but none in the same situation that I found it.  It seems like none of the reports have been fixed or confirmed.
I am using the default theme.
http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg

when you get the dialog, instead of dismissing it, attach windbg, setup symbols (per the above url) and then enter:

~* kp

*attach* the output from that command here.
Keywords: stackwanted
Blocks: 450290
No longer blocks: 450290
how do you fix this error plase contact me @ williameubnks@yahoo.com
Attached image screenshot
It happened to me as well downloading .torrent file. The only difference is thatmy firefox is not setup to open uTorrent when downloading a .torrent file. It simply downloads the file to a certain prior determined folder c:\Downloads

When the error came up, my computer had many processes running at the same time as well downloading a .torrent in Firefox. see attached screenshot.
Attached image Firefox crash R6025
This has also happened to me numerous times since upgrading from 2.0.0.18 to 2.0.0.19 (I refuse to upgrade to v.3 until Bug 438830 is fixed). Not when downloading any files, but when loading a new page, usually when surfing various forums. No particular rhyme or reason to the crash, but it happens several times a day for me and is incredibly annoying. (see Attachment #350912 [details])
sorry, your picture is useless, please read http://viper.haque.net/~timeless/blog/148/
(In reply to comment #1)
> http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg
> when you get the dialog, instead of dismissing it, attach windbg, setup symbols
> (per the above url) and then enter:
> ~* kp
> *attach* the output from that command here.

I don't know if this is what you need but I hope it will help solve this problem! Let me know if you've go more questions.

0:001> ~* kp

.  1  Id: 1784.167c Suspend: -1 Teb: 7ffdd000 Unfrozen
ChildEBP RetAddr  
01e7f97c 77499254 ntdll!KiFastSystemCallRet
01e7f980 7648c244 ntdll!ZwWaitForSingleObject+0xc
01e7f9f0 7648c1b2 kernel32!WaitForSingleObjectEx+0xbe
01e7fa04 67283bc1 kernel32!WaitForSingleObject+0x12
01e7fa14 76484911 xul!google_breakpad::ExceptionHandler::ExceptionHandlerThreadMain(void * lpParameter = 0x7747e4b6)+0x13 [e:\fx19rel\winnt_5.2_depend\mozilla\toolkit\crashreporter\google-breakpad\src\client\windows\handler\exception_handler.cc @ 212]
01e7fa20 7747e4b6 kernel32!BaseThreadInitThunk+0xe
01e7fa60 7747e489 ntdll!__RtlUserThreadStart+0x23
01e7fa78 00000000 ntdll!_RtlUserThreadStart+0x1b
I keep getting this error (R6025 Pure virtual function call) since running Firefox 3. I think it has something to do with flash. The pages that it randomly crashed on always has a flash banner. I have upgraded and re-installed flash and still the same error. This is windows XP 32 bit running 3.0.11 Firefox. Whats odd is I can still use the browser even while the error is up.
Attached image Error Box
eric: please read comment 1 carefully.
I get this error when I open the following URL:
http://web.infomoney.com.br/templates/news/view.asp?codigo=1623925&path=/investimentos/

If I don't click "Ok" in the message box where the error is shown, I can still use the browser (all opened windows and tabs). However, if I click "Ok", Firefox closes all its windows.
A few things:

- It is likely this error is triggered via external software integrating with firefox (like plugins).

- Not everyone hitting this error message is necessarily hitting the same bug. The error message is pretty generic: different people may be triggering it in completely different ways.

So if you want this fixed we really need *you* to follow the steps from comment #1 (on the page https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg ) and attach the results. Even if you found a site or list of steps that often triggered the error it is likely others could load it without ever crashing unless they have the same versions of the same extensions and plugins you do. And waiting for someone else on this bug to do this will not necessarily help getting your problem fixed.

Getting windbg set up is initially a bit of a hassle. If the instructions are hard to follow or do not work please say so. Or if you can connect to irc://irc.mozilla.org/firefox you can poke me (mzz) there and I'll try to help.
Reporter, are you still seeing this issue with Firefox 3.6.x or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2010-09-15]
Version: unspecified → 3.0 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.