make 'disabled' work for XUL checkboxes

VERIFIED FIXED in Future

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Henrik Gemal, Assigned: David Hyatt)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
In the Download Headers dialog it's possible to check/uncheck the checkbox next 
to "Mark remaining..." even if you have checked the "Download all headers".
(Reporter)

Comment 1

18 years ago
The same is true in the "Outgoing (SMTP) Server" dialog in the MailNews 
preferences.
I'm talking about the "Save my password" checkbox...

Comment 2

18 years ago
could you open a separate bug on the password?

Moving to M18 and nominating for beta3.  reassigning to sspitzer.
Assignee: putterman → sspitzer
Keywords: nsbeta3, ui

Updated

18 years ago
QA Contact: lchiang → huang

Updated

18 years ago
Target Milestone: --- → M18
(Reporter)

Comment 3

18 years ago
This must be a lower level xul problem...
checking/unchecking of disabled xul elements. hyatt?

Comment 4

18 years ago
duplicate of 30644?
(Reporter)

Comment 5

18 years ago

*** This bug has been marked as a duplicate of 30644 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
I am thinking that it's better to mark this bug depend on bug 30644.
I won't verify this bug as duplicate. -- so this way will keep us to verify this 
bug as well once bug 30644 fix....
Depends on: 30644
(Reporter)

Comment 7

18 years ago
As described in 30644 I'll reopen this bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 8

18 years ago
As per instructed in bug 30644
Assignee: sspitzer → hyatt
Status: REOPENED → NEW

Comment 9

18 years ago
->ben
Assignee: hyatt → ben

Comment 10

18 years ago
nav traige team: since bug 30644 is now fixed, please verify that this bug still happens. If it does, please assign to mail/news 
front end engineer
Whiteboard: NEED INFO
(Reporter)

Comment 11

18 years ago
This is still happening in build 2000080420! Who should it be assigned to????

Comment 12

18 years ago
Verified on commercial build all the platforms:
WinNT 08-07-15-M18
Linux 08-08-08-M18
Mac 08-08-11-M18
I think this is fix.
Verified the check/uncheck disabled item "Mark remaining headers as read" is in 
the "Download Headers" dialog when checked the "Download all headers".

Clear Status Whiteboard and marking as fixed in order to mark as verify for this 
bug.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Whiteboard: NEED INFO

Comment 13

18 years ago
Marking as verified based on above verification.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

18 years ago
This is *NOT* fixed!
I'm still able to uncheck/check an disabled item! You should not be able to 
uncheck/check an disabled item.
To reproduce:
1) Bring up the Download Headers dialog
2) Check the "Download all headers"
Now the "Mark remaning..." item is disabled, but I'm still able to uncheck/check 
it!
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 15

18 years ago
nav triage team:
reassigning to putterman - y'all figure out if this is still a problem.
Assignee: ben → putterman
Status: REOPENED → NEW
(Reporter)

Comment 16

18 years ago
"y'all figure out if this is still a problem."....
COME ON! Dont you trust me?
This is *still* a problem like I said before!
So please change the "if" -> "why"

Comment 17

18 years ago
OK. I know what's your meaning now.
By using 08-10-09-M18 commercial build
Yes. Problem is still there!!
Actual Results: I'm still able to uncheck/check an disabled item!
Expected results: shouldn't be able to uncheck/check an disabled item.

Comment 18

18 years ago
- per mail triage
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future
(Reporter)

Comment 19

18 years ago
This is now a mail/news bug. This is a bug all over Mozilla, that XUL checkboxes 
aren't really disabled!
Assignee: putterman → hyatt
Component: Mail Window Front End → XP Toolkit/Widgets
Product: MailNews → Browser
Summary: Possible to check/uncheck disabled item in "Download Headers" dialog → make 'disabled' work for XUL checkboxes
(Reporter)

Comment 20

18 years ago
"now" should have been "not"
(Assignee)

Comment 21

18 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 22

18 years ago
Build 2000083004
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.