Closed Bug 430113 Opened 13 years ago Closed 13 years ago

Landscape paper orientation does not affect real printing

Categories

(Core :: Printing: Output, defect)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 389949

People

(Reporter: tonn81, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); ru; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); ru; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

When you change paper orientation to landscape, print preview shows proper result/ But when you really print it, it prints landscape-oriented page in portrait mode.

Reproducible: Always

Steps to Reproduce:
1. Open any site
2. Go to "File"->"Page setup" and switch to "landscape"
3. Do print preview (everything is fine)
4. Print the page
Actual Results:  
Landscape page is printed in portrait mode. Content is middle vertical-aligned, and right part of it is cut (only four #, not five).

 _____
|     |
|     |
|-####|
|     |
|     |
|__ __|



Expected Results:  
Landscape page is printed in landscape mode. No content is cut.
 _____
|  |  |
|  #  |
|  #  |
|  #  |
|  #  |
|__#__|
I think is't critical to fix this bug before Firefox 3 release
Flags: blocking-firefox3?
Is this Core::Printing?
Keywords: qawanted
Component: General → Printing
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: general → printing
Version: unspecified → Trunk
This is exactly bug 389949, which was fixed on 2008-04-07.

Go to
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
to grab the latest nightly.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 389949
You need to log in before you can comment on or make changes to this bug.