"ASSERTION: subshell not in the map" calling focus() during pagehide event

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
x86
Mac OS X
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 316872 [details]
testcase

Navigating away from the testcase triggers:

###!!! ASSERTION: subshell not in the map: 'shellContent', file /Users/jruderman/trunk/mozilla/docshell/base/nsDocShell.cpp, line 3909

There are some other bugs that mention this assertion (bug 186675, bug 353408), but they involve different testcases and I can't reproduce at least one of them.
(Reporter)

Comment 1

8 years ago
WFM on trunk.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

8 years ago
Crashtest: http://hg.mozilla.org/mozilla-central/rev/f4622261cce8
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.