dir=RTL causes inconsistent mutual order of images and text

RESOLVED DUPLICATE of bug 229367

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 229367
10 years ago
9 years ago

People

(Reporter: Konstantin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

HTML source as simple as that:
<html>
<body style="direction: rtl;">
<img src="http://www.freeiconsweb.com/Icons/16x16_File_icons/Computer_File_001.gif">&nbsp;First<br>
<img src="http://www.freeiconsweb.com/Icons/16x16_File_icons/Computer_File_001.gif">&nbsp;Second<br>
</body>
</html>
(use any image you want) causes two lines to be inconsistent: in the 1-st line image is on the right side of text (correct RTL behavior), but on the 2-nd line it is on the left size (seems to be inconsistent with RTL requested) while line itself is right-aligned.

Attempt to separate lines with techniques other than "<BR>" solves the problem and restores consistent RTL behavior.

Even if I am wrong about correct behavior, there is no reason these two lines should display inconsistently.

Note: while MSIE and Safari display this correctly, Opera mysteriously (mis-)behaves consistently with Firefox.



Reproducible: Always

Steps to Reproduce:
1.Just create 6-lines HTML file as described above and load it into Firefox
2.
3.
Actual Results:  
Inconsistent display of two lines, like that:
First [Image]
[Image] Second

Expected Results:  
Like in MSIE and Safari, this should be:
First [Image]
Second [Image]
(Reporter)

Comment 1

10 years ago
Created attachment 316885 [details]
Image showing display in MSIE (on the top) and Firefox
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 229367
You need to log in before you can comment on or make changes to this bug.