If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Text displays differently in 3.0b5 vs. Firefox 2 and/or Safari

RESOLVED WONTFIX

Status

()

Core
Layout: Text
RESOLVED WONTFIX
10 years ago
10 years ago

People

(Reporter: Rick Frankel, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

The body text is incorrect in 3.0b5. I can't tell whether it is just mis-sized and leaded, or if it is the wrong font. Screenshot w/ comparison of firefox 2 vs. firefox 3 will be attached. The font should be Verdana, @ .95em (default 10pt). CSS:

   #home-secondary div, #abstract-preview {font-size:0.95em;}
    body {font-family:Verdana,Arial,sans-serif;font-size:10pt;}

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 316887 [details]
Comparison of Firefox 3 vs. Firefox 2

Comment 2

10 years ago
Firefox 3 might just be rounding the "9.5pt" size differently from Firefox 2.  Why do you claim that it's "wrong"?
Component: General → Layout: Fonts and Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: unspecified → Trunk
(Reporter)

Comment 3

10 years ago
It's wrong because Firefox 2, Safari (mac and windows) and Windows IE (6 and 7) all display the text the same (without overflowing). Only Firefox 3 causes the text to overflow the box. Firefox 2 on Linux does render slightly differently (uses more vertical space), but that may be because of font substitution. Even so, it does not overflow.

Comment 4

10 years ago
For the body text of each box, I get with (a seen with DomInspector or WebInspector)
Safari 3.1.1 : 11px
Firefox 2 : 11.4667px (rounding off to 11px)
Firefox 3 : 11.4333px (rounding off to 11.5px)
And you don't specify a line-height, leaving it to 'normal' which also results in differences between various UA. From experience, Safari is rounding down a little more than what Gecko 1.9 does.

I don't really see anything 'wrong' in what Gecko 1.9 does. It is more exact.
(Reporter)

Comment 5

10 years ago
(> And you don't specify a line-height, leaving it to 'normal' which also results
> in differences between various UA. From experience, Safari is rounding down a
> little more than what Gecko 1.9 does.

And firefox 2 and IE ...
 
> I don't really see anything 'wrong' in what Gecko 1.9 does. It is more exact.

If you don't think that rendering text quite differently than EVERY other browser (that i have acess to ;) is a problem then mark it won't fix and break a lot of web sites. 

Specifying fonts sizes in pt means that we will set the font size based on the DPI of the user's screen. That alone means that you're going to get different layouts for different users, unless you specify all dimensions (including images!!!) in physical units.

Furthermore, Firefox 3 improves our handling of DPI considerably. In Firefox 3, 72pt is always 1 inch on the screen, assuming the OS tells us the correct DPI. In Firefox 2 and possibly other browsers, this was not the case.

If you want pixel-consistent layouts across users and devices, use "px". That's what it's for.
It will be unfortunate if this breaks a lot of sites. However, we have nearly a million people using our beta releases and I haven't seen a lot of complaints about this issue. Also, our mission is to make the Web better and sometimes that means we have to break a few sites.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.