Open Bug 430175 Opened 13 years ago Updated 5 years ago

Inconsistencies with zoom keys

Categories

(Firefox :: Keyboard Navigation, defect)

x86
macOS
defect
Not set
normal

Tracking

()

UNCONFIRMED

People

(Reporter: mattsmeltz, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

There are some inconsistencies with the keys used to zoom in and out. 

Zoom Out:
  'Command' + '-' works
  'Command' + 'Shift' + '-' Does not work
  'Command' + 'Number Pad -'  ?

Zoom In:
  'Command' + '=' works but view menu on mac os x does not flash
  'Command' + 'Shift' + '=' works
  'Command' + 'Number Pad +'  ?

I can't test the + and - on the number pad since I'm on a laptop.
(Command + 0 also works but again I can't test the number pad 0.)

Is this a problem with other platforms?

Reproducible: Always
You'll be pleased to know, fixed on the Trunk :)
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401086
Thanks for the quick dupe.

That bug was for Command + + not working.  

I have a problem with Command + Shift + - not working.

And the minor problem of the view menu not flashing on Command + =

I see it was fixed by the patch for bug 359638 so it hopefully also fixed the problems I had.  Can you confirm?
I can't confirm it's fixed all your problems because I don't have a Mac, but I had near identical problems on Windows, and they all work fine now testing the equivalent to your bug on the Trunk.

Also I had a quick glance through bug 359638 before I duped this bug, to make sure there was sufficient input from Mac users, seemed to be so.
This looks like expected behavior to me.
I don't think this is a dupe of bug 359638, as I don't expect the behavior has changed.

(In reply to comment #0)
> Zoom Out:
>   'Command' + '-' works
>   'Command' + 'Shift' + '-' Does not work

Is that Command+(Shift+)_?  I wouldn't expect that to work.  Is there a reason why you want to be able to zoom out with Shift down?

> Zoom In:
>   'Command' + '=' works but view menu on mac os x does not flash

This is so that you don't /need/ to use Shift.  But I'm guessing the menu doesn't flash because the entry in the menu is for Command+(Shift+)+.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
I'm sorry if I misinterpreted, all valid points here seemed to be covered by the various dependency bugs of bug 359638, one of which is of course bug bug 401086.

I don't suppose the original author can try a nightly build out to see what issues seem resolved or not resolved for you.
(In reply to comment #4)
> This looks like expected behavior to me.
> I don't think this is a dupe of bug 359638, as I don't expect the behavior has
> changed.
> 
> (In reply to comment #0)
> > Zoom Out:
> >   'Command' + '-' works
> >   'Command' + 'Shift' + '-' Does not work
> 
> Is that Command+(Shift+)_?  I wouldn't expect that to work.  Is there a reason
> why you want to be able to zoom out with Shift down?

If I start out using Command + Shift + =  I'll want to press the - key without letting go of shift to zoom back out a level.
This is how it works in Safari.  It also works this way on Firefox 2 on my windows XP computer at work.  (Curiously, ctrl+shift+ 1-9,0,-,= all do their same functions as without using shift on Firefox 2 XP.  Maybe that's just an XP thing?)



> > Zoom In:
> >   'Command' + '=' works but view menu on mac os x does not flash
> 
> This is so that you don't /need/ to use Shift.  But I'm guessing the menu
> doesn't flash because the entry in the menu is for Command+(Shift+)+.

Yes, I think you are right about why the menu does not flash.  However, Safari flashes the menu no matter which key combination is used.
Ok, I downloaded 2.0.0.14 and latest 3.0 nightly for mac.

Firefox 2.0.0.14
-----------------
Command + Shift + - does work but does not flash view menu
(also command + shift + 1-9, and 0 work just like in the 2.0 XP version)

Command + = works but does not flash view menu

Latest nightly
-----------------
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042204 Minefield/3.0pre

Command + shift + - does not work

Command + = works but does not flash view menu

(Same results as 3b5)
I am not sure if this is a related bug, but I have been having a similar problem since firefox 2.


I am a user of the Dvorak keymap and Mac OSX. When I switch into the "DV" or "DQ" keymaps of OS 10.5, the zoom hot keys fail to work correctly. I can zoom out by holding the "Command" key and the (literal, as in on QWERTY layout) "minus/underscore" key. _Additionally_, I can do the same by holding the "Command" key and the (literal as on QWERTY) "quote" key. (I am referring to the key to the left of enter...this key is normally used to input 'minus/underscore' key in Dvorak layouts.)

 The latter should be the only correct method to zoom out in Dvorak layouts, but the real problem is that there is no way to zoom back in with any "Command" and "plus/equal" keys, using the correct Dvorak combination or the QWERTY literal combination. I either have to switch back into QWERTY and use the normal zoom hot-keys or I have to use the menu in order to view the page properly.

It is only a minor inconvenience, but it may be related to the other bugs that people are mentioning on this report.





The combinations cmd+'+', cmd+'-' and cmd+'0' are still not working with the number pad (at least on Mac OS X). Is this normal?

Tested on build Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042704 Minefield/3.0pre
(In reply to comment #9)
> The combinations cmd+'+', cmd+'-' and cmd+'0' are still not working with the
> number pad (at least on Mac OS X). Is this normal?

That doesn't sound normal to me, but it's a different issue to what is reported here.  Could you check whether behavior is any different with/without NumLock and file a separate bug please?
> That doesn't sound normal to me, but it's a different issue to what is reported
> here.  Could you check whether behavior is any different with/without NumLock
> and file a separate bug please?

Done, bug 431080

This bug was reported using Firefox 3.0 or older, which is no longer supported. The bug has also not been changed in over 500 days and is still in UNCO.
Reporter, please retest this bug in Firefox 3.6.10 or later using a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles. If you still see this problem, please update the bug. If you no longer see the bug, please set the resolution to RESOLVED, WORKSFORME.

This is a mass search of unconfirmed bugs that have no activity on them, so if you feel a bug was marked in error, just remove the CLOSEME comment in the whiteboard within the next month.
Whiteboard: [CLOSEME 2010-11-15]
This still exists in 3.6.10 and 4.0 nightly builds.  The view menu flashes now for all combinations but cmd+shift+- still does not work even though the menu flashes.
Whiteboard: [CLOSEME 2010-11-15]
Version: unspecified → Trunk
i am using fire fox 32 version and os as windows 7 
crt+shift+(-)is not working.............
Component: Menus → Keyboard Navigation
There still seems to be inconsistensies with the Zoom out button

Zoom Out:
  'Command' + '-' works and the view menu does flash
  'Command' + 'Shift' + '-' Does not work BUT the view menu does flash

Zoom In:
  'Command' + '=' works and the view menu does flash
  'Command' + 'Shift' + '=' works and the view menu does flash

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:44.0) Gecko/20100101 Firefox/44.0

(Firefox Nightly) Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:47.0) Gecko/20100101 Firefox/47.0
You need to log in before you can comment on or make changes to this bug.