Could not reply to original sender (From:) when ML inserts "Reply-To"

RESOLVED DUPLICATE of bug 77304

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 77304
10 years ago
10 years ago

People

(Reporter: Mirko Dölle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Thunderbird Version 2.0.0.12 (20080213)

When receiving mails from a mailing list which inserts a "reply-to" field into the header to allow people to reply to the list by default, Thunderbird does not allow to reply only to the original sender -- I have to delete the "reply-to" address and type in the "from:" address by hand.

In short:

Subject: My first mail to the mailing list
From: real_user@somewhere.internet
Reply-To: some_ml@mailinglist.internet
To: some_ml@mailinglist.internet


Reproducible: Always

Steps to Reproduce:
1. Open mail with "reply-to" field set by a mailing list
2. Click on "Reply" icon or right-click on the message text field, select "Reply to sender only" (sorry, translated from German "Antwort nur an Absender")
3. Thunderbird opens new mail composer window, auto-inserts the "reply-to" address in the "to" field, not the "from" address.
4. Right-click on the message text field, select "Reply to all"
5. Thunderbird opens new mail composer window, but only auto-inserts the "reply-to" address into the "to" field, there is no mail sent to the "from" address.
Actual Results:  
When using "Reply", "Reply to sender only" or "Reply to all", Thunderbird does only auto-insert the "reply-to" address into the mail composer window.

Expected Results:  
When using the "Reply" button, Thunderbird auto-insert the "reply-to" address into the "to" field (this is the current behaviour).

When selecting "Reply to sender only" by right-clicking the message text field instead, it should auto-insert the "from" address into the "to" field.

When selecting "Reply to all" by right-clicking the message text field, it should both auto-insert the "reply-to" address and the "from" address as "to" fields.

This report might sound simmilar to Bug 45715 or Bug 280851, but it's different. The first one is about resent-adresses, the later about using a reply-to address as sender.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 77304
You need to log in before you can comment on or make changes to this bug.