If URL is opened when Session Restore dialog is opened after crash, URL is opened in background and session is lost

RESOLVED DUPLICATE of bug 381386

Status

()

RESOLVED DUPLICATE of bug 381386
11 years ago
11 years ago

People

(Reporter: edmund, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

After Firefox stopped responding, I Force Quitted it, then reopened it. Before I had clicked 'Restore Previous Session' button in the Session Restore dialog, I had clicked on a URL in another application. Firefox opened the URL in the background, and then when I clicked on 'Restore Previous Session' only a blank window was opened, rather than the tabs I had opened before. Something about opening a new URL between crashing and restoring must be clobbering the session information.

Reproducible: Always

Steps to Reproduce:
1. Open some tabs in Firefox
2. Force quit Firefox so that when reopened, the Session Restore dialog appears
3. Click on a URL in another application such that it is opened in Firefox (obviously Firefox must be set as the default browser)
4. Click 'Restore Previous Session'
Actual Results:  
Only a blank page is opened, aside from the URL clicked on.

Expected Results:  
The previous session should be restored still - perhaps the URL open should not be processed until a button is clicked on in the Session Restore dialog.

I have not yet tested this on Windows, but would not be surprised if the same happened.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 381386
You need to log in before you can comment on or make changes to this bug.